aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apt
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-03 17:46:36 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-03 17:46:36 +0000
commit4b7d466fa0ed0f88f14dd381d4e00276fa3ae83e (patch)
treebd4abece3ae69cf710b48b18f22f766518441ce9 /packages/apt
parentdac73415c1d8a09ab1c085b62c566496dc2b1711 (diff)
downloadopenembedded-4b7d466fa0ed0f88f14dd381d4e00276fa3ae83e.tar.gz
apt: sync with poky
Diffstat (limited to 'packages/apt')
-rw-r--r--packages/apt/apt-0.6.45exp2/.mtn2git_empty0
-rw-r--r--packages/apt/apt-0.6.45exp2/autofoo.patch84
-rw-r--r--packages/apt/apt-0.6.45exp2/noconfigure.patch35
-rw-r--r--packages/apt/apt-0.6.45exp2/nodoc.patch15
-rw-r--r--packages/apt/apt-native.inc61
-rw-r--r--packages/apt/apt-native_0.6.45exp2.bb4
-rw-r--r--packages/apt/apt-package.inc12
-rw-r--r--packages/apt/apt.inc5
-rw-r--r--packages/apt/apt_0.6.45exp2.bb9
-rw-r--r--packages/apt/files/.mtn2git_empty0
-rw-r--r--packages/apt/files/apt.conf38
11 files changed, 257 insertions, 6 deletions
diff --git a/packages/apt/apt-0.6.45exp2/.mtn2git_empty b/packages/apt/apt-0.6.45exp2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apt/apt-0.6.45exp2/.mtn2git_empty
diff --git a/packages/apt/apt-0.6.45exp2/autofoo.patch b/packages/apt/apt-0.6.45exp2/autofoo.patch
new file mode 100644
index 0000000000..74d787cefd
--- /dev/null
+++ b/packages/apt/apt-0.6.45exp2/autofoo.patch
@@ -0,0 +1,84 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+---
+ configure.in | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+--- apt-0.6.45exp2.orig/configure.in
++++ apt-0.6.45exp2/configure.in
+@@ -18,9 +18,9 @@ AC_CONFIG_AUX_DIR(buildlib)
+ AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
+
+ dnl -- SET THIS TO THE RELEASE VERSION --
+-AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2")
++AC_DEFINE_UNQUOTED(VERSION,"0.6.45exp2",[package version])
+ PACKAGE="apt"
+-AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")
++AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE",[package name])
+ AC_SUBST(PACKAGE)
+
+ dnl Check the archs, we want the target type.
+@@ -47,7 +47,7 @@ AC_SUBST(SOCKETLIBS)
+ LIBS="$SAVE_LIBS"
+
+ dnl Checks for pthread -- disabled due to glibc bugs jgg
+-dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD) PTHREADLIB="-lpthread"])
++dnl AC_CHECK_LIB(pthread, pthread_create,[AC_DEFINE(HAVE_PTHREAD, 1, [define if we have pthreads]) PTHREADLIB="-lpthread"])
+ AC_SUBST(PTHREADLIB)
+ dnl if test "$PTHREADLIB" != "-lpthread"; then
+ dnl AC_MSG_ERROR(failed: I need posix threads, pthread)
+@@ -84,14 +84,14 @@ if test "x$archset" = "x"; then
+ AC_MSG_ERROR(failed: use --host= or check buildlib/archtable)
+ fi
+ AC_MSG_RESULT($archset)
+-AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")
++AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset",[define to the system architecture])
+
+ dnl Get a common name for the host OS - this is primarily only for HURD and is
+ dnl non fatal if it fails
+ AC_MSG_CHECKING(system OS)
+ osset="`awk \" ! /^#|^\\\$/ {if (match(\\\"$target_vendor-$target_os\\\",\\\$1)) {print \\\$2; exit}}\" $srcdir/buildlib/ostable`"
+ AC_MSG_RESULT($osset)
+-AC_DEFINE_UNQUOTED(COMMON_OS,"$osset")
++AC_DEFINE_UNQUOTED(COMMON_OS,"$osset",[define to the system OS])
+
+ dnl We use C99 types if at all possible
+ AC_CACHE_CHECK([for C99 integer types],c9x_ints,[
+@@ -105,13 +105,13 @@ AC_SUBST(HAVE_STATVFS)
+
+ dnl Arg, linux and bsd put their statfs function in different places
+ if test x"$HAVE_STATVFS" != x"yes"; then
+- AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H)],[
+- AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H)],[AC_MSG_ERROR(failed: Need statvfs)])
++ AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H, 1, [define if statfs is in sys/vfs.h])],[
++ AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H, 1, [define if statfs is in sys/mount.h])],[AC_MSG_ERROR(failed: Need statvfs)])
+ ])
+ fi
+
+ dnl We should use the real timegm function if we have it.
+-AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM))
++AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM, 1, [define if we have timegm]))
+ AC_SUBST(HAVE_TIMEGM)
+
+ dnl Check the sizes etc. of the architecture
+@@ -157,7 +157,7 @@ fi
+ dnl HP-UX sux..
+ AC_MSG_CHECKING(for missing socklen_t)
+ AC_EGREP_HEADER(socklen_t, sys/socket.h,[AC_MSG_RESULT(no)],[
+- AC_DEFINE(NEED_SOCKLEN_T_DEFINE)
++ AC_DEFINE(NEED_SOCKLEN_T_DEFINE, 1, [define if we need to define socklen_t])
+ NEED_SOCKLEN_T_DEFINE=yes
+ AC_MSG_RESULT(missing.)])
+ AC_SUBST(NEED_SOCKLEN_T_DEFINE)
+@@ -204,7 +204,7 @@ dnl gettext approved makefiles, so this
+ ALL_LINGUAS="bg bs ca cs cy da de dz el en_GB es eu fi fr gl hu it ja ko nb nl nn pl pt_BR pt ro ru sk sl sv tl vi zn_CN zh_TW"
+ AM_GNU_GETTEXT(external)
+ if test x"$USE_NLS" = "xyes"; then
+- AC_DEFINE(USE_NLS)
++ AC_DEFINE(USE_NLS, 1, [define if we have native language support])
+ fi
+ AC_SUBST(USE_NLS)
+ AC_PATH_PROG(BASH, bash)
diff --git a/packages/apt/apt-0.6.45exp2/noconfigure.patch b/packages/apt/apt-0.6.45exp2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/packages/apt/apt-0.6.45exp2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/packages/apt/apt-0.6.45exp2/nodoc.patch b/packages/apt/apt-0.6.45exp2/nodoc.patch
new file mode 100644
index 0000000000..9101847189
--- /dev/null
+++ b/packages/apt/apt-0.6.45exp2/nodoc.patch
@@ -0,0 +1,15 @@
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- apt-0.6.45exp2.orig/Makefile
++++ apt-0.6.45exp2/Makefile
+@@ -17,7 +17,7 @@ all headers library clean veryclean bina
+ $(MAKE) -C cmdline $@
+ $(MAKE) -C ftparchive $@
+ $(MAKE) -C dselect $@
+- $(MAKE) -C doc $@
++# $(MAKE) -C doc $@
+ $(MAKE) -C po $@
+
+ # Some very common aliases
diff --git a/packages/apt/apt-native.inc b/packages/apt/apt-native.inc
new file mode 100644
index 0000000000..de9426bf70
--- /dev/null
+++ b/packages/apt/apt-native.inc
@@ -0,0 +1,61 @@
+require apt.inc
+inherit native
+
+DEPENDS += "dpkg-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
+PACKAGES = ""
+USE_NLS = "no"
+
+python do_stage () {
+ bb.build.exec_func('do_stage_base', d)
+ bb.build.exec_func('do_stage_config', d)
+}
+
+python do_stage_config () {
+ indir = os.path.dirname(bb.data.getVar('FILE',d,1))
+ infile = file(os.path.join(indir, 'files', 'apt.conf'), 'r')
+ data = infile.read()
+ infile.close()
+
+ data = bb.data.expand(data, d)
+
+ outdir = os.path.join(bb.data.getVar('sysconfdir', d, 1), 'apt')
+ if not os.path.exists(outdir):
+ os.makedirs(outdir)
+ outpath = os.path.join(outdir, 'apt.conf')
+
+ outfile = file(outpath, 'w')
+ outfile.write(data)
+ outfile.close()
+}
+
+do_stage_base () {
+ install -d ${bindir}
+ install -m 0755 bin/apt-cdrom ${bindir}/
+ install -m 0755 bin/apt-get ${bindir}/
+ install -m 0755 bin/apt-config ${bindir}/
+ install -m 0755 bin/apt-cache ${bindir}/
+
+ install -m 0755 bin/apt-sortpkgs ${bindir}/
+ install -m 0755 bin/apt-extracttemplates ${bindir}/
+
+ eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${libdir}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${libdir}/libapt-inst.so
+
+ install -d ${libdir}/apt/methods
+ install -m 0755 bin/methods/* ${libdir}/apt/methods/
+
+ install -d ${libdir}/dpkg/methods/apt
+ install -m 0644 dselect/desc.apt ${libdir}/dpkg/methods/apt/
+ install -m 0644 dselect/names ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/install ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/setup ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/update ${libdir}/dpkg/methods/apt/
+
+ install -d ${sysconfdir}/apt
+ install -d ${localstatedir}/lib/apt/lists/partial
+ install -d ${localstatedir}/cache/apt/archives/partial
+}
diff --git a/packages/apt/apt-native_0.6.45exp2.bb b/packages/apt/apt-native_0.6.45exp2.bb
new file mode 100644
index 0000000000..43f73889f7
--- /dev/null
+++ b/packages/apt/apt-native_0.6.45exp2.bb
@@ -0,0 +1,4 @@
+require apt-native.inc
+
+SRC_URI += "file://nodoc.patch;patch=1 \
+ file://noconfigure.patch;patch=1"
diff --git a/packages/apt/apt-package.inc b/packages/apt/apt-package.inc
index 8c54741547..43f54cadab 100644
--- a/packages/apt/apt-package.inc
+++ b/packages/apt/apt-package.inc
@@ -36,7 +36,7 @@ apt-utils-manpages="doc/apt-extracttemplates.1 \
def get_files_apt_doc(d, bb, manpages):
import re
manpages = re.sub(r'\bdoc/(\S+)/(\S+)\.\1\.(.)\b', r'${mandir}/\1/man\3/\2.\3', manpages)
- manpages = re.sub(r'\bdoc/(\S+)\.(.)\b', r'${mandir}/man\3/\1.\3', manpages)
+ manpages = re.sub(r'\bdoc/(\S+)\.(.)\b', r'${mandir}/man\2/\1.\2', manpages)
return manpages
def get_commands_apt_doc(d, bb, manpages):
@@ -65,6 +65,7 @@ FILES_${PN}-utils-doc = "${@get_files_apt_doc(d, bb, bb.data.getVar('apt-utils-m
FILES_${PN}-dev = "${libdir}/libapt*.so"
do_install () {
+ set -x
${@get_commands_apt_doc(d, bb, bb.data.getVar('apt-manpages', d, 1))}
${@get_commands_apt_doc(d, bb, bb.data.getVar('apt-utils-manpages', d, 1))}
install -d ${D}${bindir}
@@ -76,10 +77,11 @@ do_install () {
install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
- oe_libinstall -so -C bin libapt-pkg--6 ${D}${libdir}/
- ln -sf libapt-pkg--6.so ${D}${libdir}/libapt-pkg.so
- oe_libinstall -so -C bin libapt-inst--6 ${D}${libdir}/
- ln -sf libapt-inst--6.so ${D}${libdir}/libapt-inst.so
+ eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${D}${libdir}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${D}${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${D}${libdir}/libapt-inst.so
install -d ${D}${libdir}/apt/methods
install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
diff --git a/packages/apt/apt.inc b/packages/apt/apt.inc
index d03016b277..b18ed93782 100644
--- a/packages/apt/apt.inc
+++ b/packages/apt/apt.inc
@@ -1,7 +1,10 @@
DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz"
S = "${WORKDIR}/apt-${PV}"
+
+inherit autotools gettext
+
+EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
diff --git a/packages/apt/apt_0.6.45exp2.bb b/packages/apt/apt_0.6.45exp2.bb
new file mode 100644
index 0000000000..1cd8eb270e
--- /dev/null
+++ b/packages/apt/apt_0.6.45exp2.bb
@@ -0,0 +1,9 @@
+require apt.inc
+
+SRC_URI += "file://autofoo.patch;patch=1 \
+ file://nodoc.patch;patch=1"
+
+require apt-package.inc
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
diff --git a/packages/apt/files/.mtn2git_empty b/packages/apt/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apt/files/.mtn2git_empty
diff --git a/packages/apt/files/apt.conf b/packages/apt/files/apt.conf
new file mode 100644
index 0000000000..37785871db
--- /dev/null
+++ b/packages/apt/files/apt.conf
@@ -0,0 +1,38 @@
+Dir "${STAGING_DIR}/"
+{
+ State "var/lib/apt/"
+ {
+ Lists "lists/";
+ status "${IMAGE_ROOTFS}/var/dpkg/status";
+ };
+ Cache "var/cache/apt/"
+ {
+ Archives "archives/";
+ pkgcache "";
+ srcpkgcache "";
+ };
+ Bin "${STAGING_BINDIR}/"
+ {
+ methods "${STAGING_LIBDIR}/apt/methods/";
+ gzip "/bin/gzip";
+ dpkg "dpkg";
+ dpkg-source "dpkg-source";
+ dpkg-buildpackage "dpkg-buildpackage";
+ apt-get "apt-get";
+ apt-cache "apt-cache";
+ };
+};
+
+APT
+{
+ Immediate-Configure "false";
+ Architecture "i586";
+ Get
+ {
+ Assume-Yes "true";
+ Force-Yes "true"
+ };
+};
+
+DPkg::Options {"--root=${IMAGE_ROOTFS}";"--admindir=${IMAGE_ROOTFS}/var/dpkg";"--force-all";"--no-debsig"};
+};