aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apr
diff options
context:
space:
mode:
authorMustafa Yuecel <yuecelm@ee.ethz.ch>2005-08-18 21:02:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-18 21:02:46 +0000
commit70746d76649dce56539d0040bcade781fa083cd6 (patch)
tree6e5c6d8998391e7921edf1318956521af71f6333 /packages/apr
parent75d01547a53ad17ec85783eb778eea6df9478122 (diff)
downloadopenembedded-70746d76649dce56539d0040bcade781fa083cd6.tar.gz
add apr and apr-util: needed for subversion
Diffstat (limited to 'packages/apr')
-rw-r--r--packages/apr/.mtn2git_empty0
-rw-r--r--packages/apr/apr-util_1.1.2.bb26
-rw-r--r--packages/apr/apr_1.1.1.bb23
3 files changed, 49 insertions, 0 deletions
diff --git a/packages/apr/.mtn2git_empty b/packages/apr/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/apr/.mtn2git_empty
diff --git a/packages/apr/apr-util_1.1.2.bb b/packages/apr/apr-util_1.1.2.bb
new file mode 100644
index 0000000000..35cc787e6c
--- /dev/null
+++ b/packages/apr/apr-util_1.1.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.gz"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+
+ oe_runconf
+
+}
+
+do_stage() {
+
+ oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
+
+}
diff --git a/packages/apr/apr_1.1.1.bb b/packages/apr/apr_1.1.1.bb
new file mode 100644
index 0000000000..74dbe5185a
--- /dev/null
+++ b/packages/apr/apr_1.1.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Apache Portable Runtime (APR) library"
+SECTION = "libs"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.bz2"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+
+ oe_runconf
+
+}
+
+do_stage() {
+
+ oe_libinstall -a -so -C .libs libapr-1 ${STAGING_LIBDIR}
+
+}