aboutsummaryrefslogtreecommitdiffstats
path: root/packages/altboot
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-02-02 00:52:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-02 00:52:41 +0000
commit69f2223275267fbb7428c305c9ee67eb73c8068d (patch)
treed59a979a29292a74445f390e430a6fb078539a06 /packages/altboot
parent6d0cbb9292836080fe20feb2e450dd61a4a71019 (diff)
downloadopenembedded-69f2223275267fbb7428c305c9ee67eb73c8068d.tar.gz
altboot: Bugfixes
- Fix disable_printk.sh - Boot NFS: Ignore failure of mounting /proc
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot.bb2
-rw-r--r--packages/altboot/files/altboot-menu/15-bootSD4
-rw-r--r--packages/altboot/files/altboot-menu/Advanced/40-bootNFS2
-rw-r--r--packages/altboot/files/altboot-menu/Advanced/55-bin-sh5
-rw-r--r--packages/altboot/files/altboot.rc/disable_printk.sh4
-rw-r--r--packages/altboot/files/init.altboot1
6 files changed, 13 insertions, 5 deletions
diff --git a/packages/altboot/altboot.bb b/packages/altboot/altboot.bb
index a6b2bcb524..0a349c62d8 100644
--- a/packages/altboot/altboot.bb
+++ b/packages/altboot/altboot.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
IGNORE_STRIP_ERRORS = "1"
-PR = "r16"
+PR = "r17"
SRC_URI = "file://altboot-menu \
diff --git a/packages/altboot/files/altboot-menu/15-bootSD b/packages/altboot/files/altboot-menu/15-bootSD
index d086cde344..baa85a7cf7 100644
--- a/packages/altboot/files/altboot-menu/15-bootSD
+++ b/packages/altboot/files/altboot-menu/15-bootSD
@@ -15,11 +15,13 @@ die() {
# This function is activated by init.altboot by calling this script with the "run" option
run_module() {
- test -e /etc/altboot.func && . /etc/altboot.func || die "ERROR: /etc/altboot.func not found. Check your installation!"
+ test -e /etc/altboot.func && . /etc/altboot.func || die "ERROR: /etc/altboot.func not found. Check your installation!"
echo -n "Mounting rootfs rw..." >/dev/tty0
mount -o remount,rw / >/dev/tty0 2>&1 && echo ok >/dev/tty0|| die "mount -o remount,rw / failed"
+ mount proc -t proc /proc >/dev/tty0 2>&1
+
echo -n "Generating device files..." >/dev/tty0
/etc/init.d/devices start && echo ok >/dev/tty0|| die "FAILED"
diff --git a/packages/altboot/files/altboot-menu/Advanced/40-bootNFS b/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
index e83a2867c5..7279ba66ee 100644
--- a/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
+++ b/packages/altboot/files/altboot-menu/Advanced/40-bootNFS
@@ -23,7 +23,7 @@ run_module() {
/etc/init.d/devices start && echo ok >/dev/tty0|| die "FAILED"
echo -n "Mounting /proc..." >/dev/tty0
- mount /proc >/dev/tty0 2>&1 && echo ok >/dev/tty0 || echo failed
+ mount /proc >/dev/tty0 >/dev/null 2>&1 && echo ok >/dev/tty0 || echo failed
# Needed for NFS
/etc/init.d/portmap start >/dev/tty1 2>&1 || die "/etc/init.d/portmap start failed!"
diff --git a/packages/altboot/files/altboot-menu/Advanced/55-bin-sh b/packages/altboot/files/altboot-menu/Advanced/55-bin-sh
index 6db4adaf3a..90a6f37ff5 100644
--- a/packages/altboot/files/altboot-menu/Advanced/55-bin-sh
+++ b/packages/altboot/files/altboot-menu/Advanced/55-bin-sh
@@ -8,6 +8,11 @@ run_module() {
test "$ASK_PW_ON_BOOT" != "yes" && verify_master_pw >/dev/tty0
+ # Make the system a little bit more usable than a standard init=/bin/sh boot
+ mount -t proc proc /proc >/dev/null 2>&1
+ uname -r | grep -q "2.6." && mount sys -t sysfs /sys
+ mount -o remount,rw /
+
echo -e "\nBoot system with 'exec /sbin/init 5'\n"
while true
do
diff --git a/packages/altboot/files/altboot.rc/disable_printk.sh b/packages/altboot/files/altboot.rc/disable_printk.sh
index 9d5f918c1e..af15adec44 100644
--- a/packages/altboot/files/altboot.rc/disable_printk.sh
+++ b/packages/altboot/files/altboot.rc/disable_printk.sh
@@ -1,4 +1,6 @@
-#!/bin/bash
+#!/bin/sh
+
+mount proc -t proc /proc >/dev/null 2>&1
echo 0 > /proc/sys/kernel/printk
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index cd8b6b8929..2ef804d99c 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -24,7 +24,6 @@ case "`uname -r`" in
ALTBOOT_CFG_FILE="/etc/altboot-2.6.cfg";;
esac
-echo "Using [${ALTBOOT_CFG_FILE}]"
test -e "$ALTBOOT_CFG_FILE" && . "$ALTBOOT_CFG_FILE" || echo "WARNING: No $ALTBOOT_CFG_FILE found! Check your installation of Altboot!" > /dev/tty1
C_RED="\033[31m"