aboutsummaryrefslogtreecommitdiffstats
path: root/packages/addons
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-31 10:06:49 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-31 10:06:49 +0000
commit366aedf113c20538a6628eb1a880c4b2800812db (patch)
tree6e2366c3b3b52b75ddf18318b61f26f8227238c0 /packages/addons
parentd0d87d1d948f5fa77e6d3e407f6ce19de2a97279 (diff)
downloadopenembedded-366aedf113c20538a6628eb1a880c4b2800812db.tar.gz
devshell: do not try to package but deploy it
Diffstat (limited to 'packages/addons')
-rw-r--r--packages/addons/devshell.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/packages/addons/devshell.bb b/packages/addons/devshell.bb
index d8116dd48b..986e17a5f9 100644
--- a/packages/addons/devshell.bb
+++ b/packages/addons/devshell.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Runs a shell in an environment as emitted by BitBake to execute tasks"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
inherit autotools pkgconfig
@@ -55,7 +55,7 @@ do_stage() {
:
}
-do_package() {
+do_deploy() {
shellfile="${TARGET_PREFIX}${DISTRO}-${MACHINE}-devshell"
cd ${WORKDIR}
@@ -71,3 +71,5 @@ do_package() {
mkdir -p ${DEPLOY_DIR}/addons
install -m 755 $shellfile ${DEPLOY_DIR}/addons
}
+
+addtask do_deploy after do_install