aboutsummaryrefslogtreecommitdiffstats
path: root/matrixssl
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /matrixssl
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'matrixssl')
-rw-r--r--matrixssl/matrixssl-1.0-beta/cross.patch28
-rw-r--r--matrixssl/matrixssl-1.1.1/cross.patch55
2 files changed, 83 insertions, 0 deletions
diff --git a/matrixssl/matrixssl-1.0-beta/cross.patch b/matrixssl/matrixssl-1.0-beta/cross.patch
index e69de29bb2..b4c9634949 100644
--- a/matrixssl/matrixssl-1.0-beta/cross.patch
+++ b/matrixssl/matrixssl-1.0-beta/cross.patch
@@ -0,0 +1,28 @@
+--- src/Makefile~cross 2004-03-01 19:12:37.000000000 -0500
++++ src/Makefile 2004-06-04 21:59:55.527364588 -0400
+@@ -12,14 +12,14 @@
+ #
+ # Debug flags and C flags
+ #
+-DFLAGS = -O3
++CFLAGS = -O3
+ #
+ # To build a debug version of the MatrixSSL library, uncomment the DFLAGS line
+ # below and remove the strip command in the .so target below.
+ #
+-#DFLAGS = -g -DDEBUG
++#CFLAGS = -g -DDEBUG
+
+-CFLAGS = -DLINUX $(DFLAGS)
++override CFLAGS += -DLINUX
+ LDFLAGS = -Wl -lc -lpthread
+
+ all: compile
+@@ -56,7 +56,6 @@
+ #
+ libmatrixssl.so: $(OBJECTS)
+ $(CC) -shared -nostdlib -o $@ $^ $(LDFLAGS)
+- strip $(LIBRARIES)
+
+ #
+ # Clean up workspace
diff --git a/matrixssl/matrixssl-1.1.1/cross.patch b/matrixssl/matrixssl-1.1.1/cross.patch
index e69de29bb2..05ae0523e8 100644
--- a/matrixssl/matrixssl-1.1.1/cross.patch
+++ b/matrixssl/matrixssl-1.1.1/cross.patch
@@ -0,0 +1,55 @@
+--- src/Makefile.porig 2004-06-10 15:03:25.000000000 -0400
++++ src/Makefile 2004-06-11 20:16:30.701134886 -0400
+@@ -6,7 +6,7 @@
+ #
+
+ CC = gcc
+-STRIP = strip
++STRIP = -s
+ O = .o
+ SO = .so
+ E =
+@@ -37,17 +37,17 @@
+ #
+ ifdef MATRIXSSL_DEBUG
+ DFLAGS = -g -Wall -DDEBUG
+-STRIP = test
++STRIP =
+ else
+-DFLAGS = -O3
++DFLAGS = -O2
+ endif
+
+ #
+ # Compile options
+ #
+-SHARED = -shared
+-CFLAGS = $(DFLAGS) -DLINUX
+-LDFLAGS = -nostdlib -lc -lpthread
++SHARED = -shared
++CFLAGS = $(DFLAGS) $(STRIP) -DLINUX
++LDLIBS = -nostdlib -lc -lpthread
+
+ #
+ # Override variables for compilation on Mac OS X (Darwin)
+@@ -57,8 +57,8 @@
+ SO = .dylib
+ SHARED = -dynamiclib
+ CFLAGS += -DOSX -isystem -I/usr/include
+-LDFLAGS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
+-STRIP = test
++LDLIBS = -flat_namespace -install_name @executable_path/../src/$(LIBRARY)
++STRIP =
+ endif
+
+ all: compile
+@@ -77,8 +77,7 @@
+ # Build the library
+ #
+ $(LIBRARY): $(OBJECTS)
+- $(CC) $(SHARED) -o $@ $^ $(LDFLAGS)
+- $(STRIP) $(LIBRARY)
++ $(CC) $(SHARED) -o $@ $^ $(LDFLAGS) $(LDLIBS)
+
+ #
+ # Clean up all generated files