aboutsummaryrefslogtreecommitdiffstats
path: root/libmpeg2
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-05-22 16:47:36 +0000
committerChris Larson <clarson@kergoth.com>2004-05-22 16:47:36 +0000
commit2b8f679ffe5929b5a11eb71e514aa4997c36f13e (patch)
treecab0f25aca03f6162bd268a401945fbfbb63bff9 /libmpeg2
parent5df179157f90b18f437c6978efb451f515e3d1c9 (diff)
downloadopenembedded-2b8f679ffe5929b5a11eb71e514aa4997c36f13e.tar.gz
Merges.
2004/05/22 12:46:48-04:00 local!kergoth Bugfixes per the recent FILESDIR cleanup. 2004/05/22 01:03:38-04:00 local!kergoth Run a perl script against the repo to kill off direct FILESDIR usage in favor of relative file:// paths in SRC_URI, and WORKDIR references in functions. 2004/05/21 23:07:58-04:00 local!kergoth Switch file:// FILESDIR uris in SRC_URI to the new relative path format. BKrev: 40af8428aNyDLBX0MRtyso3VCpMv1w
Diffstat (limited to 'libmpeg2')
-rw-r--r--libmpeg2/libmpeg2_0.4.0b.oe22
1 files changed, 22 insertions, 0 deletions
diff --git a/libmpeg2/libmpeg2_0.4.0b.oe b/libmpeg2/libmpeg2_0.4.0b.oe
index e69de29bb2..fa550467e5 100644
--- a/libmpeg2/libmpeg2_0.4.0b.oe
+++ b/libmpeg2/libmpeg2_0.4.0b.oe
@@ -0,0 +1,22 @@
+DESCRIPTION = "MPEG Video Decoder Library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Tim Ansell <ipks@mithis.net>"
+DEPENDS = "virtual/libc virtual/libsdl"
+
+SRC_URI = "http://libmpeg2.sourceforge.net/files/mpeg2dec-${PV}.tar.gz \
+ file://Makefile.patch;patch=1 "
+S = "${WORKDIR}/mpeg2dec-0.4.0"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-shared"
+
+do_stage() {
+ oe_libinstall -a -so -C libmpeg2 libmpeg2 ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libmpeg2/convert libmpeg2convert ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/mpeg2dec/
+ install -m 0644 include/mpeg2.h ${STAGING_INCDIR}/mpeg2dec/
+ install -m 0644 include/mpeg2convert.h ${STAGING_INCDIR}/mpeg2dec/
+}