aboutsummaryrefslogtreecommitdiffstats
path: root/libetpan
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /libetpan
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'libetpan')
-rw-r--r--libetpan/libetpan-cvs/config_iconv.patch22
-rw-r--r--libetpan/libetpan-cvs/destdir.patch60
-rw-r--r--libetpan/libetpan-cvs/gcc34.patch16
-rw-r--r--libetpan/libetpan-cvs/includedir.patch11
-rw-r--r--libetpan/libetpan-cvs/mailstream_socket.patch36
-rw-r--r--libetpan/libetpan-cvs/pkgconfig.patch45
-rw-r--r--libetpan/libetpan-cvs/smtptls.patch28
7 files changed, 218 insertions, 0 deletions
diff --git a/libetpan/libetpan-cvs/config_iconv.patch b/libetpan/libetpan-cvs/config_iconv.patch
index e69de29bb2..1a6d9d1928 100644
--- a/libetpan/libetpan-cvs/config_iconv.patch
+++ b/libetpan/libetpan-cvs/config_iconv.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/configure.in~config_iconv 2004-03-07 01:59:00.000000000 +0100
++++ libetpan-0.33pre/configure.in 2004-04-07 16:30:42.286805212 +0200
+@@ -92,14 +92,6 @@
+ fi
+ AC_SUBST(SSLLIBS)
+
+-dnl iconv
+-AC_ARG_ENABLE(iconv,
+- [ --disable-iconv make a version not using iconv],
+- enable_iconv=no, enable_iconv=yes)
+-if test x$enable_iconv = xyes; then
+- AM_ICONV
+-fi
+-
+ dnl Berkeley DB
+
+ DBVERS=0
diff --git a/libetpan/libetpan-cvs/destdir.patch b/libetpan/libetpan-cvs/destdir.patch
index e69de29bb2..c8cc60f709 100644
--- a/libetpan/libetpan-cvs/destdir.patch
+++ b/libetpan/libetpan-cvs/destdir.patch
@@ -0,0 +1,60 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/Rules.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Rules.in 2004-07-22 14:56:56.132455370 +0200
+@@ -3,6 +3,7 @@
+ # each submakefile should define SOURCES and TARGET
+ # optionnaly HEADRS and INCLUDES
+
++DESTDIR =
+ srcdir = $(top_builddir)/src
+ prefix = @prefix@
+ includedir = @includedir@/libetpan
+@@ -37,7 +38,7 @@
+ # install headers here only
+ install: $(HEADERS) install-recursive
+ for header in $(HEADERS); do \
+- $(INSTALL) -m 644 "$$header" $(includedir) ; \
++ $(INSTALL) -m 644 $$header $(DESTDIR)$(includedir)/libetpan ; \
+ done
+
+ Makefile: $(top_builddir)/Rules
+--- libetpan-0.33pre/Makefile.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Makefile.in 2004-07-22 14:59:17.321980703 +0200
+@@ -51,13 +51,13 @@
+ done && test -z "$$fail"
+
+ install: all install-dirs install-recursive
+- $(INSTALL) -m 755 libetpan-config $(bindir)
+- $(INSTALL) -m 644 libetpan-config.h $(includedir)/libetpan
++ $(INSTALL) -m 755 libetpan-config $(DESTDIR)$(bindir)
++ $(INSTALL) -m 644 libetpan-config.h $(DESTDIR)$(includedir)/libetpan
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(includedir)
+- $(INSTALL) -d -m 755 $(includedir)/libetpan
+- $(INSTALL) -d -m 755 $(bindir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/libetpan
++ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+
+ #realclean: maintainer-clean
+
+--- libetpan-0.33pre/src/Makefile.in~destdir 2004-05-02 18:16:58.000000000 +0200
++++ libetpan-0.33pre/src/Makefile.in 2004-07-22 15:04:02.581981625 +0200
+@@ -38,10 +38,10 @@
+ $(SUBLIBS): all-recursive
+
+ install: all install-dirs install-recursive
+- $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(libdir)
++ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(DESTDIR)$(libdir)
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(libdir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(libdir)
+
+ clean: clean-recursive
+ rm $(TARGET)
diff --git a/libetpan/libetpan-cvs/gcc34.patch b/libetpan/libetpan-cvs/gcc34.patch
index e69de29bb2..5420c2f6d1 100644
--- a/libetpan/libetpan-cvs/gcc34.patch
+++ b/libetpan/libetpan-cvs/gcc34.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/src/driver/implementation/imap/imapdriver_cached_message.c~gcc34 2003-12-08 16:36:36.000000000 +0100
++++ libetpan-0.33pre/src/driver/implementation/imap/imapdriver_cached_message.c 2004-07-22 14:49:02.459902029 +0200
+@@ -212,7 +212,7 @@
+ mmap_string_free(gstr);
+ free_section:
+ mailmime_section_free(part);
+- err:
++ err:;
+ }
+
+ static void generate_key_from_section(char * key, size_t size,
diff --git a/libetpan/libetpan-cvs/includedir.patch b/libetpan/libetpan-cvs/includedir.patch
index e69de29bb2..1a23f0f705 100644
--- a/libetpan/libetpan-cvs/includedir.patch
+++ b/libetpan/libetpan-cvs/includedir.patch
@@ -0,0 +1,11 @@
+--- Rules.in.orig 2003-12-15 17:11:13.000000000 -0500
++++ Rules.in 2004-04-10 22:33:55.000000000 -0400
+@@ -36,7 +36,7 @@
+ # install headers here only
+ install: $(HEADERS)
+ for header in $(HEADERS); do \
+- $(INSTALL) -m 644 $$header $(includedir) ; \
++ $(INSTALL) -m 644 $$header $(includedir)/libetpan ; \
+ done
+
+ Makefile: ../Rules
diff --git a/libetpan/libetpan-cvs/mailstream_socket.patch b/libetpan/libetpan-cvs/mailstream_socket.patch
index e69de29bb2..b02ce46a04 100644
--- a/libetpan/libetpan-cvs/mailstream_socket.patch
+++ b/libetpan/libetpan-cvs/mailstream_socket.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/tools/mailstream_socket.c~mailstream_socket 2004-03-07 01:59:01.000000000 +0100
++++ libetpan-0.33pre/tools/mailstream_socket.c 2004-03-11 14:48:47.000000000 +0100
+@@ -44,6 +44,7 @@
+ */
+ #include <sys/time.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <unistd.h>
+ #include <sys/select.h>
+
+@@ -176,8 +177,8 @@
+ if (!FD_ISSET(socket_data->fd, &fds_read))
+ return 0;
+ }
+-
+- return read(socket_data->fd, buf, count);
++
++ return recv(socket_data->fd,buf,count,MSG_NOSIGNAL);
+ }
+
+ static ssize_t mailstream_low_socket_write(mailstream_low * s,
+@@ -207,8 +208,7 @@
+ if (!FD_ISSET(socket_data->fd, &fds_write))
+ return 0;
+ }
+-
+- return write(socket_data->fd, buf, count);
++ return send(socket_data->fd,buf,count,MSG_NOSIGNAL);
+ }
+
+
diff --git a/libetpan/libetpan-cvs/pkgconfig.patch b/libetpan/libetpan-cvs/pkgconfig.patch
index e69de29bb2..dcbfa20d64 100644
--- a/libetpan/libetpan-cvs/pkgconfig.patch
+++ b/libetpan/libetpan-cvs/pkgconfig.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/configure.in~pkgconfig 2004-07-14 18:13:06.000000000 -0500
++++ libetpan-0.33pre/configure.in 2004-07-15 19:03:18.000000000 -0500
+@@ -198,7 +198,7 @@
+ AC_SUBST(VERSION)
+
+
+-AC_OUTPUT(Makefile Rules libetpan-config generic/libetpan_version.h)
++AC_OUTPUT(Makefile Rules libetpan-config libetpan.pc generic/libetpan_version.h)
+
+ dnl includes that depend on configure
+
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ libetpan-0.33pre/libetpan.pc.in 2004-07-15 19:06:41.000000000 -0500
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libetpan
++Description: a mail library
++Version: @VERSION@
++Libs: -L${libdir} -letpan @LDFLAGS@ @LIBS@ @SSLLIBS@ @LIBICONV@ @DBLIB@
++Cflags: -I${includedir}
+--- libetpan-0.33pre/Makefile.in~pkgconfig 2004-07-15 19:05:01.000000000 -0500
++++ libetpan-0.33pre/Makefile.in 2004-07-15 19:04:54.000000000 -0500
+@@ -64,11 +64,13 @@
+ $(INSTALL) -m 755 libetpan-config $(bindir)
+ $(INSTALL) -m 644 libetpan-config.h $(includedir)/libetpan
+ $(INSTALL) -m 644 generic/libetpan.h $(includedir)
++ $(INSTALL) -m 644 libetpan.pc $(libdir)/pkgconfig
+
+ install-dirs:
+ $(INSTALL) -d -m 755 $(includedir)
+ $(INSTALL) -d -m 755 $(includedir)/libetpan
+ $(INSTALL) -d -m 755 $(libdir)
++ $(INSTALL) -d -m 755 $(libdir)/pkgconfig
+ $(INSTALL) -d -m 755 $(bindir)
+
+ realclean: maintainer-clean
diff --git a/libetpan/libetpan-cvs/smtptls.patch b/libetpan/libetpan-cvs/smtptls.patch
index e69de29bb2..d790d78ea2 100644
--- a/libetpan/libetpan-cvs/smtptls.patch
+++ b/libetpan/libetpan-cvs/smtptls.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/smtp/mailsmtp_helper.c~smtptls 2004-03-11 14:29:59.000000000 +0100
++++ libetpan-0.33pre/smtp/mailsmtp_helper.c 2004-02-12 22:07:24.000000000 +0100
+@@ -42,19 +42,14 @@
+ {
+ int r;
+
++ session->esmtp = 0;
+ r = mailesmtp_ehlo(session);
+
+ if (r == MAILSMTP_NO_ERROR) {
+- session->esmtp = TRUE;
+ return MAILSMTP_NO_ERROR;
+ }
+
+ r = mailsmtp_helo(session);
+- if (r == MAILSMTP_NO_ERROR) {
+- session->esmtp = FALSE;
+- return MAILSMTP_NO_ERROR;
+- }
+-
+ return r;
+ }
+