aboutsummaryrefslogtreecommitdiffstats
path: root/hostap
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-08-11 10:09:07 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-08-11 10:09:07 +0000
commitea14ee0065cc5314ee27c7c0a68eb8ecd917b008 (patch)
tree9c800eef62f7984e97e6efe6292e817176a16239 /hostap
parent54e2de0d20e23722196110fe5f10fc55ad4201a1 (diff)
downloadopenembedded-ea14ee0065cc5314ee27c7c0a68eb8ecd917b008.tar.gz
- split up hostap-modules package into hostap-modules, hostap-modules-cs, and hostap-modules-pci. patch courtesy Bruno Randolf.
- adjust machine configurations to RDEPEND on hostap-modules-cs. BKrev: 4119f043tj69uFyok2N7HpTooC3AQA
Diffstat (limited to 'hostap')
-rw-r--r--hostap/hostap-modules-0.2.4/mtx_compat.diff0
-rw-r--r--hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff0
-rw-r--r--hostap/hostap-modules_0.2.4.oe13
3 files changed, 12 insertions, 1 deletions
diff --git a/hostap/hostap-modules-0.2.4/mtx_compat.diff b/hostap/hostap-modules-0.2.4/mtx_compat.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/hostap/hostap-modules-0.2.4/mtx_compat.diff
diff --git a/hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff b/hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/hostap/hostap-modules-0.2.4/mtx_hostap_deferred_irq.diff
diff --git a/hostap/hostap-modules_0.2.4.oe b/hostap/hostap-modules_0.2.4.oe
index 04d1817ff9..9925ce7afb 100644
--- a/hostap/hostap-modules_0.2.4.oe
+++ b/hostap/hostap-modules_0.2.4.oe
@@ -8,14 +8,18 @@ PR = "r1"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
file://hostap_cs.conf \
file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+ file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
S = "${WORKDIR}/hostap-driver-${PV}"
inherit module
# Hack Alert :D
+ARCH_mipsel = "mips"
MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
-NET_MODULES = "hostap.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
+NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
do_install() {
install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
@@ -29,3 +33,10 @@ do_install() {
install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"