aboutsummaryrefslogtreecommitdiffstats
path: root/gpe-bluetooth
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /gpe-bluetooth
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'gpe-bluetooth')
-rw-r--r--gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch30
-rw-r--r--gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch12
2 files changed, 42 insertions, 0 deletions
diff --git a/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch b/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
index e69de29bb2..d18cb38aac 100644
--- a/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
+++ b/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
@@ -0,0 +1,30 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-bluetooth/main.c,v
+retrieving revision 1.51
+retrieving revision 1.52
+diff -u -r1.51 -r1.52
+--- main.c 7 Mar 2004 17:41:27 -0000 1.51
++++ main.c 7 Sep 2004 00:01:17 -0000 1.52
+@@ -508,7 +508,7 @@
+ {
+ GtkWidget *window;
+ GdkBitmap *bitmap;
+- GtkWidget *menu_remove, *menu_file;
++ GtkWidget *menu_remove;
+ GtkTooltips *tooltips;
+ int dd;
+
+@@ -560,12 +560,10 @@
+
+ gtk_widget_show (menu_devices);
+ gtk_widget_show (menu_remove);
+- gtk_widget_show (menu_file);
+
+ gtk_menu_append (GTK_MENU (menu), menu_radio_on);
+ gtk_menu_append (GTK_MENU (menu), menu_radio_off);
+ gtk_menu_append (GTK_MENU (menu), menu_devices);
+- gtk_menu_append (GTK_MENU (menu), menu_file);
+ gtk_menu_append (GTK_MENU (menu), menu_remove);
+
+ if (gpe_load_icons (my_icons) == FALSE)
diff --git a/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch b/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
index e69de29bb2..009b9a576f 100644
--- a/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
+++ b/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
@@ -0,0 +1,12 @@
+diff -urNd ../gpe-bluetooth-0.37-r0/gpe-bluetooth-0.37/Makefile gpe-bluetooth-0.37/Makefile
+--- ../gpe-bluetooth-0.37-r0/gpe-bluetooth-0.37/Makefile 2004-09-07 01:01:06.000000000 +0100
++++ gpe-bluetooth-0.37/Makefile 2004-10-18 11:55:53.000000000 +0100
+@@ -20,7 +20,7 @@
+ PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS) `pkg-config --cflags dbus-glib-1` `pkg-config --cflags libglade-2.0` `pkg-config --cflags mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --cflags $(LIBGPEVTYPE_PC)`
+ PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS) -DDBUS_API_SUBJECT_TO_CHANGE -DGPE_BLUETOOTH
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+-PACKAGE_LDFLAGS += $(GPELIBS) -lbluetooth -lsdp `pkg-config --libs gthread-2.0` `pkg-config --libs dbus-glib-1` `pkg-config --libs libglade-2.0` -lopenobex `pkg-config --libs mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --libs $(LIBGPEVTYPE_PC)` -lsqlite
++PACKAGE_LDFLAGS += $(GPELIBS) -lbluetooth -lbluetooth `pkg-config --libs gthread-2.0` `pkg-config --libs dbus-glib-1` `pkg-config --libs libglade-2.0` -lopenobex `pkg-config --libs mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --libs $(LIBGPEVTYPE_PC)` -lsqlite
+
+ ifeq ($(CVSBUILD),yes)
+ BUILD = ../build