aboutsummaryrefslogtreecommitdiffstats
path: root/fam
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /fam
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'fam')
-rw-r--r--fam/fam-2.6.10/rpcsvc.patch17
-rw-r--r--fam/fam-2.7.0/compile-fix.patch27
2 files changed, 44 insertions, 0 deletions
diff --git a/fam/fam-2.6.10/rpcsvc.patch b/fam/fam-2.6.10/rpcsvc.patch
index e69de29bb2..ce36beb634 100644
--- a/fam/fam-2.6.10/rpcsvc.patch
+++ b/fam/fam-2.6.10/rpcsvc.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.6.10/fam/Makefile.am~rpcsvc 2003-04-15 00:21:26.000000000 -0400
++++ fam-2.6.10/fam/Makefile.am 2004-03-05 10:43:32.000000000 -0500
+@@ -76,7 +76,8 @@
+
+ EXTRA_fam_SOURCES = IMonIrix.c++ IMonLinux.c++ IMonNone.c++
+
+-fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++#fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++fam_LDADD = $(top_srcdir)/support/libsupport.a
+
+ CLEANFILES += @MKDEPFILE@ ii_files/*.ii
+ sinclude @MKDEPFILE@
diff --git a/fam/fam-2.7.0/compile-fix.patch b/fam/fam-2.7.0/compile-fix.patch
index e69de29bb2..cb9c702af5 100644
--- a/fam/fam-2.7.0/compile-fix.patch
+++ b/fam/fam-2.7.0/compile-fix.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.7.0/src/Listener.c++~compile-fix 2003-01-20 01:37:29.000000000 +0100
++++ fam-2.7.0/src/Listener.c++ 2004-02-28 23:53:57.000000000 +0100
+@@ -45,7 +45,7 @@
+ #include "BTree.h"
+
+ #if !(HAVE_BINDRESVPORT_PROTO)
+-extern "C" int bindresvport(int sd, struct sockaddr_in *);
++extern "C" int bindresvport(int sd, struct sockaddr_in *) throw();
+ #endif
+
+ struct NegotiatingClient
+--- fam-2.7.0/src/Log.c++~compile-fix 2003-01-18 15:18:12.000000000 +0100
++++ fam-2.7.0/src/Log.c++ 2004-02-29 02:23:23.000000000 +0100
+@@ -264,7 +264,7 @@
+ // New back end for assert() will log to syslog, put core file
+ // in known directory.
+
+-void __assert(const char *msg, const char *file, int line)
++void __assert(const char *msg, const char *file, int line) throw()
+ {
+ char *dirname = new char[strlen(Log::getName()) + 20];
+ (void) sprintf(dirname, "/usr/tmp/%s.%d", Log::getName(), getpid());