aboutsummaryrefslogtreecommitdiffstats
path: root/classes/pkgconfig.oeclass
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-07 22:05:47 +0000
committerChris Larson <clarson@kergoth.com>2004-12-07 22:05:47 +0000
commita780643c4b6aa11e1a36965a69df7116477c7b4c (patch)
tree17e81e77bde19931facf9b30fa5b5981df796071 /classes/pkgconfig.oeclass
parent88cce8db7ebf88ab9da2366a2ac21a5a723340b8 (diff)
downloadopenembedded-a780643c4b6aa11e1a36965a69df7116477c7b4c.tar.gz
Merge oe-devel@oe-devel.bkbits.net:packages.bb
into handhelds.org:/home/kergoth/code/packages.bb 2004/12/07 04:58:25-06:00 ti.com!kergoth More updates per the core rename. 2004/12/07 04:46:51-06:00 ti.com!kergoth Update soundtracker per the core rename. 2004/12/07 04:44:14-06:00 ti.com!kergoth Merge 2004/12/07 04:42:38-06:00 ti.com!kergoth Updates per the recent rename of the oe core from 'oe' to 'bitbake'. BKrev: 41b6293b91LRHSxMOt6WnrZVAdLbFw
Diffstat (limited to 'classes/pkgconfig.oeclass')
-rw-r--r--classes/pkgconfig.oeclass28
1 files changed, 0 insertions, 28 deletions
diff --git a/classes/pkgconfig.oeclass b/classes/pkgconfig.oeclass
deleted file mode 100644
index 5e15a2ac97..0000000000
--- a/classes/pkgconfig.oeclass
+++ /dev/null
@@ -1,28 +0,0 @@
-inherit base
-
-DEPENDS_prepend = "pkgconfig-native "
-
-# The namespaces can clash here hence the two step replace
-def get_pkgconfig_mangle(d):
- import oe.data
- s = "-e ''"
- if not oe.data.inherits_class('native', d):
- s += " -e 's:${libdir}:OELIBDIR:;'"
- s += " -e 's:${includedir}:OEINCDIR:;'"
- s += " -e 's:${datadir}:OEDATADIR:'"
- s += " -e 's:${prefix}:OEPREFIX:'"
- s += " -e 's:${exec_prefix}:OEEXECPREFIX:'"
- s += " -e 's:OELIBDIR:${STAGING_LIBDIR}:;'"
- s += " -e 's:OEINCDIR:${STAGING_INCDIR}:;'"
- s += " -e 's:OEDATADIR:${STAGING_DATADIR}:'"
- s += " -e 's:OEPREFIX:${STAGING_LIBDIR}/..:'"
- s += " -e 's:OEEXECPREFIX:${STAGING_LIBDIR}/..:'"
- return s
-
-do_stage_append () {
- for pc in `find ${S} -name '*.pc'`; do
- pcname=`basename $pc`
- install -d ${PKG_CONFIG_PATH}
- cat $pc | sed ${@get_pkgconfig_mangle(d)} > ${PKG_CONFIG_PATH}/$pcname
- done
-}