aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-14 14:18:40 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-14 14:20:07 -0700
commitbc159cc29ee70370aa85aa5628b13c21792cb4a7 (patch)
treeb270cec32f37748f31e418ad4bbc692df105ff2b
parent94a9ba7988f0d6586ecaf0b722d6b320cfdf94ae (diff)
downloadopenembedded-bc159cc29ee70370aa85aa5628b13c21792cb4a7.tar.gz
libproxy: Define __USE_BSD before its needed.
This fixed a build break on uclibc where it complained armv5te-oe-linux-uclibcgnueabi/usr/include/stdlib.h:215: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'strtouq' The reason is u_quad_t is only defined if __USE_BSD is defined Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gnome/files/libproxy-move-define-__USE_BSD.patch17
-rw-r--r--recipes/gnome/libproxy_0.2.3.bb6
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/gnome/files/libproxy-move-define-__USE_BSD.patch b/recipes/gnome/files/libproxy-move-define-__USE_BSD.patch
new file mode 100644
index 0000000000..b65b3608d4
--- /dev/null
+++ b/recipes/gnome/files/libproxy-move-define-__USE_BSD.patch
@@ -0,0 +1,17 @@
+Index: libproxy-0.2.3/src/lib/dns.c
+===================================================================
+--- libproxy-0.2.3.orig/src/lib/dns.c 2009-08-14 14:13:21.123557812 -0700
++++ libproxy-0.2.3/src/lib/dns.c 2009-08-14 14:13:31.954575500 -0700
+@@ -17,11 +17,11 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ ******************************************************************************/
+
++#define __USE_BSD
+ #include <string.h>
+ #include <errno.h>
+ #include <stdio.h>
+ #include <netdb.h>
+-#define __USE_BSD
+ #include <unistd.h>
+
+ #include "misc.h"
diff --git a/recipes/gnome/libproxy_0.2.3.bb b/recipes/gnome/libproxy_0.2.3.bb
index c04be6b5f3..fd405cba77 100644
--- a/recipes/gnome/libproxy_0.2.3.bb
+++ b/recipes/gnome/libproxy_0.2.3.bb
@@ -2,7 +2,11 @@ DESCRIPTION = "A library handling all the details of proxy configuration"
LICENSE = "LGPL"
DEPENDS = "libxmu gconf virtual/libx11"
-SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz"
+PR = "r1"
+
+SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz \
+ file://libproxy-move-define-__USE_BSD.patch;patch=1 \
+ "
inherit autotools_stage