aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-08-13 09:51:49 +0200
committerKoen Kooi <koen@openembedded.org>2009-08-13 09:51:49 +0200
commit7d61ab869f54314accc7d1df54cb38a425723be0 (patch)
tree3ea3ce82937e957f066ed5850374950a86706b80
parentca8509346cfa1613e8952a5706e486fa774b8fe8 (diff)
downloadopenembedded-7d61ab869f54314accc7d1df54cb38a425723be0.tar.gz
u-boot git: update beagleboard pinmux file
-rw-r--r--recipes/u-boot/u-boot-git/new-pinmux.patch28
-rw-r--r--recipes/u-boot/u-boot_git.bb2
2 files changed, 17 insertions, 13 deletions
diff --git a/recipes/u-boot/u-boot-git/new-pinmux.patch b/recipes/u-boot/u-boot-git/new-pinmux.patch
index 63963db097..1c8fa16598 100644
--- a/recipes/u-boot/u-boot-git/new-pinmux.patch
+++ b/recipes/u-boot/u-boot-git/new-pinmux.patch
@@ -1,16 +1,8 @@
-From: Steve Sakoman <sakoman@tera.(none)>
-Date: Thu, 16 Apr 2009 05:08:11 +0000 (-0700)
-Subject: beagle: first cut at pinmux to support tincan zippy
-X-Git-Url: http://www.sakoman.net/cgi-bin/gitweb.cgi?p=u-boot-omap3.git;a=commitdiff_plain;h=22223c0fe848871a6c2ecfcdd292c7d6d38b1d1d
-
-beagle: first cut at pinmux to support tincan zippy
----
-
diff --git a/board/omap3/beagle/beagle.h b/board/omap3/beagle/beagle.h
-index fe18223..e3f0da0 100644
+index 00b15cb..36eae5c 100644
--- a/board/omap3/beagle/beagle.h
+++ b/board/omap3/beagle/beagle.h
-@@ -203,16 +203,16 @@ const omap3_sysinfo sysinfo = {
+@@ -201,16 +201,16 @@ const omap3_sysinfo sysinfo = {
MUX_VAL(CP(MMC1_DAT6), (IEN | PTU | EN | M0)) /*MMC1_DAT6*/\
MUX_VAL(CP(MMC1_DAT7), (IEN | PTU | EN | M0)) /*MMC1_DAT7*/\
/*Wireless LAN */\
@@ -37,7 +29,7 @@ index fe18223..e3f0da0 100644
/*Bluetooth*/\
MUX_VAL(CP(MCBSP3_DX), (IEN | PTD | DIS | M1)) /*UART2_CTS*/\
MUX_VAL(CP(MCBSP3_DR), (IDIS | PTD | DIS | M1)) /*UART2_RTS*/\
-@@ -231,13 +231,13 @@ const omap3_sysinfo sysinfo = {
+@@ -229,13 +229,13 @@ const omap3_sysinfo sysinfo = {
MUX_VAL(CP(MCBSP4_DR), (IEN | PTD | DIS | M1)) /*SSI1_FLAG_RX*/\
MUX_VAL(CP(MCBSP4_DX), (IEN | PTD | DIS | M1)) /*SSI1_RDY_RX*/\
MUX_VAL(CP(MCBSP4_FSX), (IEN | PTD | DIS | M1)) /*SSI1_WAKE*/\
@@ -57,7 +49,7 @@ index fe18223..e3f0da0 100644
/*Serial Interface*/\
MUX_VAL(CP(UART3_CTS_RCTX), (IEN | PTD | EN | M0)) /*UART3_CTS_RCTX*/\
MUX_VAL(CP(UART3_RTS_SD), (IDIS | PTD | DIS | M0)) /*UART3_RTS_SD */\
-@@ -257,8 +257,8 @@ const omap3_sysinfo sysinfo = {
+@@ -255,8 +255,8 @@ const omap3_sysinfo sysinfo = {
MUX_VAL(CP(HSUSB0_DATA7), (IEN | PTD | DIS | M0)) /*HSUSB0_DATA7*/\
MUX_VAL(CP(I2C1_SCL), (IEN | PTU | EN | M0)) /*I2C1_SCL*/\
MUX_VAL(CP(I2C1_SDA), (IEN | PTU | EN | M0)) /*I2C1_SDA*/\
@@ -68,4 +60,16 @@ index fe18223..e3f0da0 100644
MUX_VAL(CP(I2C3_SCL), (IEN | PTU | EN | M0)) /*I2C3_SCL*/\
MUX_VAL(CP(I2C3_SDA), (IEN | PTU | EN | M0)) /*I2C3_SDA*/\
MUX_VAL(CP(I2C4_SCL), (IEN | PTU | EN | M0)) /*I2C4_SCL*/\
+@@ -374,9 +374,9 @@ const omap3_sysinfo sysinfo = {
+ MUX_VAL(CP(SDRC_CKE1), (IDIS | PTU | EN | M0)) /*sdrc_cke1*/
+ #define MUX_BEAGLE_C() \
+- MUX_VAL(CP(MCBSP3_DX), (IEN | PTD | DIS | M4)) /*GPIO_140*/\
+- MUX_VAL(CP(MCBSP3_DR), (IEN | PTD | DIS | M4)) /*GPIO_142*/\
+- MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTD | DIS | M4)) /*GPIO_141*/\
++ MUX_VAL(CP(MCBSP3_DX), (IEN | PTD | DIS | M4)) /*GPIO_140*/\
++ MUX_VAL(CP(MCBSP3_DR), (IEN | PTD | DIS | M4)) /*GPIO_142*/\
++ MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTD | DIS | M4)) /*GPIO_141*/\
+ MUX_VAL(CP(UART2_CTS), (IEN | PTU | EN | M0)) /*UART2_CTS*/\
+ MUX_VAL(CP(UART2_RTS), (IDIS | PTD | DIS | M0)) /*UART2_RTS*/\
+ MUX_VAL(CP(UART2_TX), (IDIS | PTD | DIS | M0)) /*UART2_TX*/
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index c646813278..4537e54099 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r27"
+PR ="r28"
FILESPATHPKG =. "u-boot-git:"