aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-11 22:31:33 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-11 22:31:33 +0100
commitd436f4f6a5dcd8a2f15a9dc4cc11a6132e4075eb (patch)
tree565a7b948490bfada6942338702756840ebd9f5d
parentf3ddf3a7f46546a3fc792643a36503edc6b5e9ce (diff)
parent32a3192b142bf0d89b7d9ede4fde65d3d877ddd6 (diff)
downloadopenembedded-d436f4f6a5dcd8a2f15a9dc4cc11a6132e4075eb.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--conf/checksums.ini4
-rw-r--r--packages/dsplink/ti-codec-combos_3.16.bb45
2 files changed, 39 insertions, 10 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 235c481845..2a373d137c 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8542,6 +8542,10 @@ sha256=a7ec60003a96975523598c2ef5f2927c9a362e689e7159b268c7fe431754635a
md5=7ba3d2592585c8bcf9d3bf1aafeefef3
sha256=609e24aa1413b1053ee3fd42c36c6ccf05d8067867021511c7d50d4829875b44
+[http://gpe.linuxtogo.org/download/source/gpe-scap-1.4.tar.bz2]
+md5=eaf545561b0ad981c9d01833f30fcf95
+sha256=762778421fae7c62d5ec6a9d27986166c0dbbe2ff51fc10bb9b8baff5c367534
+
[http://gpe.linuxtogo.org/download/source/gpe-session-scripts-0.67.tar.gz]
md5=774c64ed54455f1297ecbeeffdc52eed
sha256=da051f5049d44415fff02b48368db4e3e3b6154135a50f990844d73896d18e19
diff --git a/packages/dsplink/ti-codec-combos_3.16.bb b/packages/dsplink/ti-codec-combos_3.16.bb
index ae9edee4ae..923e9eeff2 100644
--- a/packages/dsplink/ti-codec-combos_3.16.bb
+++ b/packages/dsplink/ti-codec-combos_3.16.bb
@@ -4,25 +4,47 @@ LICENCE = "unknown"
require ti-paths.inc
-# TODO update this...
-# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
-# Install the above link and put the omap3530_dvsdk_combos_3_16.tar.gz file in the same directory as this recipe
-SRC_URI = "file://omap3530_dvsdk_combos_3_16.tar.gz \
- "
+SRC_URI = "http://software-dl.ti.com/sdo/sdo_apps_public_sw/omap3530_dvsdk_combos_tspa/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin \
+ "
S = "${WORKDIR}/omap3530_dvsdk_combos_3_16"
+
# Yes, the xdc stuff still breaks with a '.' in PWD
PV = "316"
-PR = "r11"
+PR = "r12"
TARGET = "all"
export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/packages;${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
+# Needed for now since makefile in latest package assumes this is set
+export CODEC_INSTALL_DIR="${S}"
+
+# Helper function to run the binary installer and unpack the tar.gz in the same place as it was before - this could be optimised later
+do_accept_license() {
+ export HOME="${WORKDIR}"
+ chmod +x ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin
+ ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin --mode silent --prefix ${S}_install
+ cd "${S}_install"
+ tar -xzvf omap3530_dvsdk_combos_tspa_3_16.tar.gz
+ if [ -d ${S} ] ; then
+ rm -rf ${S}
+ fi
+ mv omap3530_dvsdk_combos_tspa_3_16 ${S}
+}
+
+addtask accept_license after do_unpack before do_configure
+
do_compile() {
- sed -i -e s:/db/toolsrc/library/vendors2005/ti/c6x/6.0.16/Linux:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
- -e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
- -e s:/home/dvsdkval/workdir/OMAP3530/nfs/workdir/opt/toolchain/arm-2007q3:${CROSS_DIR}:g \
+
+ # For now, remove the reference to Rules.make and swap prod for eval, since this only has eval libs included
+ sed -i \
+ -e '/Rules.make/d' \
+ -e s:prod:eval:g \
+ ${S}/Makefile
+
+ # Fix-up config.bld to swap out hardcoded references to tools paths
+ sed -i -e s:/opt/dmsw/cg6x_6_0_16:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
${S}/config.bld
oe_runmake clean
@@ -41,7 +63,10 @@ do_install () {
install ${i} ${D}/${datadir}/ti-codec-combos
done
- # should copy the generated data sheets as well for reference
+ # copy the generated data sheets as well for reference
+ for i in $(find . -name "*.DataSheet.*") ; do
+ install ${i} ${D}/${datadir}/ti-codec-combos
+ done
}
do_stage () {