aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-06-06 14:45:48 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-06-06 14:45:48 +0000
commit9499ab1e95b21471373670a1338ee6c5a3e4bc50 (patch)
tree30ac7d1f7ebd6f186f6345c2b864c9c4f01c0e54
parent75520ee66f1fa1d21b33f72f9ae19823b6f7d38c (diff)
downloadopenembedded-9499ab1e95b21471373670a1338ee6c5a3e4bc50.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into marsco.kalmiopsis:/home/nslu2/openembedded 2005/06/06 15:42:51+02:00 utwente.nl!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into bitbake.utwente.nl:/home/koen/OE/openembedded 2005/06/06 15:42:10+02:00 utwente.nl!koen Fix ts.conf so it actually parses, courtesy Florian Boor 2005/06/06 14:40:46+01:00 reciva.com!pb tweak device node creation in lirc-modules postinst 2005/06/06 14:36:41+01:00 reciva.com!pb need to call "initscript stop" in prerm, not postrm 2005/06/06 13:27:26+02:00 mn-solutions.de!schurig MNCI "Ramses": get rid of my experimental arm-linuxeabi TARGET_ARCH 2005/06/06 13:25:41+02:00 mn-solutions.de!schurig make modutils-cross compile again, tip from do13 on IRC 2005/06/06 13:10:24+02:00 utwente.nl!koen xserver-kdrive-omap_6.6.3.bb: tweak xserver-omap, courtesy Florian Boor 2005/06/06 12:40:49+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/06/06 12:40:28+02:00 uni-frankfurt.de!mickeyl openzaurus-3.5.4: bump CVSDATE 2005/06/06 10:18:58+01:00 reciva.com!pb remove gcc_csl-arm preference on armeb 2005/06/06 10:15:53+01:00 reciva.com!pb disable ifupdown-spurious-environ patch due to segfaults on armeb 2005/06/06 11:04:32+02:00 utwente.nl!koen nokia770.conf: remove unneeded orinoco driver BKrev: 42a4619cgEf5_eucbkPjTgBmQzeUMw
-rw-r--r--classes/update-rc.d.bbclass2
-rw-r--r--conf/distro/openmnci.conf5
-rw-r--r--conf/distro/openzaurus-3.5.4.conf2
-rw-r--r--conf/machine/nokia770.conf1
-rw-r--r--packages/busybox/busybox_1.00.bb4
-rw-r--r--packages/gcc/gcc_csl-arm-20050603.bb1
-rw-r--r--packages/lirc/lirc-modules_0.7.1.bb34
-rw-r--r--packages/modutils/files/gcc4.patch (renamed from packages/modutils/modutils-2.4.27/gcc4.patch)0
-rw-r--r--packages/tslib/tslib-maemo/nokia770/ts.conf2
-rw-r--r--packages/tslib/tslib-maemo/nokia770/tslib.sh5
-rw-r--r--packages/xserver/xserver-kdrive-omap_6.6.3.bb24
11 files changed, 70 insertions, 10 deletions
diff --git a/classes/update-rc.d.bbclass b/classes/update-rc.d.bbclass
index 5f256b28af..e3f7963baa 100644
--- a/classes/update-rc.d.bbclass
+++ b/classes/update-rc.d.bbclass
@@ -14,7 +14,7 @@ fi
update-rc.d $D ${INITSCRIPT_NAME} ${INITSCRIPT_PARAMS}
}
-updatercd_postrm() {
+updatercd_prerm() {
if test "x$D" != "x"; then
D="-r $D"
else
diff --git a/conf/distro/openmnci.conf b/conf/distro/openmnci.conf
index fc1b05516c..87d8e2e6b4 100644
--- a/conf/distro/openmnci.conf
+++ b/conf/distro/openmnci.conf
@@ -3,5 +3,6 @@ INHERIT += "debian"
OEINCLUDELOGS = "yes"
KERNEL_CONSOLE = "ttyS0"
-#TARGET_FPU = ""
-TARGET_ARCH = "arm-linuxeabi"
+TARGET_OS = "linux"
+TARGET_FPU = "soft"
+#TARGET_ARCH = "arm-linuxeabi"
diff --git a/conf/distro/openzaurus-3.5.4.conf b/conf/distro/openzaurus-3.5.4.conf
index 384c9b8a47..0591d49918 100644
--- a/conf/distro/openzaurus-3.5.4.conf
+++ b/conf/distro/openzaurus-3.5.4.conf
@@ -14,7 +14,7 @@ FEED_URIS += " \
console##http://openzaurus.org/official/unstable/3.5.3/feed/console \
devel##http://openzaurus.org/official/unstable/3.5.3/feed/devel"
-CVSDATE = "20050528"
+CVSDATE = "20050607"
#
# Zaurus
diff --git a/conf/machine/nokia770.conf b/conf/machine/nokia770.conf
index f1e2b96a34..f017726526 100644
--- a/conf/machine/nokia770.conf
+++ b/conf/machine/nokia770.conf
@@ -31,7 +31,6 @@ SERIAL_CONSOLE = "115200 ttyS0"
#build omap1 till nokia releases the patches
PREFERRED_PROVIDER_virtual/kernel = "linux-omap1"
-PREFERRED_VERSION_orinoco-modules = "0.15rc1"
BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel udev sysfsutils \
pcmcia-cs apmd ppp wireless-tools console-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin"
diff --git a/packages/busybox/busybox_1.00.bb b/packages/busybox/busybox_1.00.bb
index ccea9e8718..57fb359c1d 100644
--- a/packages/busybox/busybox_1.00.bb
+++ b/packages/busybox/busybox_1.00.bb
@@ -12,9 +12,6 @@ SECTION = "base"
PRIORITY = "required"
PR = "r24"
-SPURION = "file://ifupdown-spurious-environ.patch;patch=1"
-SPURION_nslu2 = ""
-
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://add-getkey-applet.patch;patch=1 \
file://udhcpscript.patch;patch=1 \
@@ -30,7 +27,6 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://mount-all-type.patch;patch=1 \
file://celf-ash-builtins.patch;patch=1 \
file://dhcp-hostname.patch;patch=1 \
- ${SPURION} \
file://gzip-spurious-const.patch;patch=1 \
file://defconfig \
file://busybox-cron \
diff --git a/packages/gcc/gcc_csl-arm-20050603.bb b/packages/gcc/gcc_csl-arm-20050603.bb
index e4cadb0232..43bf828203 100644
--- a/packages/gcc/gcc_csl-arm-20050603.bb
+++ b/packages/gcc/gcc_csl-arm-20050603.bb
@@ -11,6 +11,5 @@ CVSDATE = "20050603"
OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
DEFAULT_PREFERENCE_arm = "1"
-DEFAULT_PREFERENCE_armeb = "1"
DEFAULT_PREFERENCE_nslu2 = "-1"
diff --git a/packages/lirc/lirc-modules_0.7.1.bb b/packages/lirc/lirc-modules_0.7.1.bb
index e69de29bb2..a230078a71 100644
--- a/packages/lirc/lirc-modules_0.7.1.bb
+++ b/packages/lirc/lirc-modules_0.7.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel fakeroot-native"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
+ file://lirc_sir-sa1100.patch;patch=1"
+S = "${WORKDIR}/lirc-${PV}"
+
+inherit autotools module-base
+
+include lirc-config.inc
+
+do_compile() {
+ # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
+ cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
+}
+
+fakeroot do_install() {
+ oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
+ rm -rf ${D}/dev
+}
+
+pkg_postinst() {
+#!/bin/sh
+set -e
+if [ ! -c ${D}/dev/lirc ]; then mknod ${D}/dev/lirc c 61 0; fi
+exit 0
+}
+
+FILES_${PN} = "/lib/modules"
diff --git a/packages/modutils/modutils-2.4.27/gcc4.patch b/packages/modutils/files/gcc4.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/modutils/modutils-2.4.27/gcc4.patch
+++ b/packages/modutils/files/gcc4.patch
diff --git a/packages/tslib/tslib-maemo/nokia770/ts.conf b/packages/tslib/tslib-maemo/nokia770/ts.conf
index e69de29bb2..24b00839e9 100644
--- a/packages/tslib/tslib-maemo/nokia770/ts.conf
+++ b/packages/tslib/tslib-maemo/nokia770/ts.conf
@@ -0,0 +1,2 @@
+module pressure
+module linear \ No newline at end of file
diff --git a/packages/tslib/tslib-maemo/nokia770/tslib.sh b/packages/tslib/tslib-maemo/nokia770/tslib.sh
index e69de29bb2..d31bc76368 100644
--- a/packages/tslib/tslib-maemo/nokia770/tslib.sh
+++ b/packages/tslib/tslib-maemo/nokia770/tslib.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+TSLIB_TSDEVICE=`detect-stylus --device`
+
+export TSLIB_TSDEVICE
diff --git a/packages/xserver/xserver-kdrive-omap_6.6.3.bb b/packages/xserver/xserver-kdrive-omap_6.6.3.bb
index e69de29bb2..e4eed066dd 100644
--- a/packages/xserver/xserver-kdrive-omap_6.6.3.bb
+++ b/packages/xserver/xserver-kdrive-omap_6.6.3.bb
@@ -0,0 +1,24 @@
+LICENSE = "MIT"
+DEPENDS = "xsp tslib-maemo xproto xdmcp xextensions xtrans xau x11 xext libxrandr fixesext damageext xfont resourceext compositeext xcalibrateext recordext"
+RDEPENDS = "libts-0.0-0"
+PROVIDES = "virtual/xserver"
+PACKAGES = "${PN} ${PN}-doc ${PN}-dev ${PN}-locale"
+SECTION = "x11/base"
+DESCRIPTION = "X server from freedesktop.org"
+DESCRIPTION_xserver-kdrive-omap = "X server from freedesktop.org with patches from maemo.org, supporting X on OMAP based devices"
+
+PR = "r1"
+
+FILES_${PN} = "${bindir}/Xomap"
+
+SRC_URI = " http://stage.maemo.org/pool/maemo/ossw/source/x/xserver-kdrive/xserver-kdrive_${PV}-5.tar.gz \
+ file://kmode.patch;patch=1 \
+ file://fbdev-not-fix.patch;patch=1 \
+ file://configure-tslib.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/xserver"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-composite --disable-xinerama --enable-xomapserver \
+ --enable-xsp --disable-xlocale --disable-rpath --prefix=/usr"