aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-01-09 21:09:12 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-01-09 21:35:51 +0100
commitc5b4df259e8158e6f68f7d144b4bcad9b2eca9c9 (patch)
tree430b7b749fd0bc97de92f46d74a6ac82f36cea50
parent4092253536e36714f75810f3f1a28ffb4a4cc8fc (diff)
downloadopenembedded-c5b4df259e8158e6f68f7d144b4bcad9b2eca9c9.tar.gz
xkeyboard-config: add git version(has htcdream keyboard support)
This version add the (upstream) support for htc dream. The support for the htcdream is composed the 'us','it','de' keyboards and has the extra-keys like | - _ etc... mapped. But no custom keys(keys that weren't printed on the keyboard were mapped yet, and some bugs are present for the htc dream) The DEFAULT_PREFERENCE = "-1" is because of that(from #oe on FreeNode on irc): Jan 09 21:04:39 <Jay7> or commit with DP=-1 then post request to ML about promoting to default Jan 09 21:04:48 <GNUtoo|laptop> ok I'll send to ml Jan 09 21:05:14 <GNUtoo|laptop> I push some other stuff that only touch htcdream, and get thoses on ml Jan 09 21:05:15 <hrw> push with dp-1 first Jan 09 21:05:18 <GNUtoo|laptop> ok Jan 09 21:07:11 <GNUtoo|laptop> maybe I put DP -1 for all but not for SHR In other words xkeyboard-config is used by a lot of distros/machines (all the machines which have a keyboard), and as it's a git version, so it's safer not to affect everyone in the case of a bug. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/xkeyboard-config/xkeyboard-config_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/xkeyboard-config/xkeyboard-config_git.bb b/recipes/xkeyboard-config/xkeyboard-config_git.bb
new file mode 100644
index 0000000000..5fc0a77a7a
--- /dev/null
+++ b/recipes/xkeyboard-config/xkeyboard-config_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Common X11 Keyboard layouts"
+LICENSE = "MIT"
+DEPENDS = "intltool xkbcomp-native"
+RDEPENDS_${PN} = "xkbcomp"
+SRCREV = "547ae8589afb208d7b44ffe1e0ff7aba466c2ee3"
+PV = "2.0+gitr${SRCPV}"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_shr = "1"
+
+SRC_URI = "git://anongit.freedesktop.org/xkeyboard-config;protocol=git;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_install_append () {
+ install -d ${D}/usr/share/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}
+
+FILES_${PN} += "${datadir}/X11/xkb"