aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-10 10:08:59 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-10 10:10:05 -0700
commit8229cb1214867b14890015924089858b429ccd6c (patch)
tree30e7d42e6ded1fdea17ca419f0501a1b2afb4efb
parentd344300c57dc0fc4a8505c7c7979bdee6d86e6da (diff)
downloadopenembedded-8229cb1214867b14890015924089858b429ccd6c.tar.gz
libnl2: Fix a race on route/pktloc_syntax.h
At issue is that route/pktloc.c (not generated) depends on route/pktloc_syntax.h (generated). Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch23
-rw-r--r--recipes/libnl/libnl2_2.0.bb2
-rw-r--r--recipes/libnl/libnl2_git.bb3
3 files changed, 27 insertions, 1 deletions
diff --git a/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch b/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000000..d396f963b4
--- /dev/null
+++ b/recipes/libnl/libnl2/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,23 @@
+---
+ lib/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,14 @@ CLEANFILES = \
+ route/pktloc_grammar.c route/pktloc_grammar.h \
+ route/pktloc_syntax.c route/pktloc_syntax.h
+
++BUILT_SOURCES = route/pktloc_syntax.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(YACC) -d $(YFLAGS) -o $@ $^
+
diff --git a/recipes/libnl/libnl2_2.0.bb b/recipes/libnl/libnl2_2.0.bb
index b2d1a4e84e..7e50f3b4d1 100644
--- a/recipes/libnl/libnl2_2.0.bb
+++ b/recipes/libnl/libnl2_2.0.bb
@@ -3,6 +3,7 @@ SECTION = "libs/network"
LICENSE = "LGPL"
HOMEPAGE = "http://www.infradead.org/~tgr/libnl/"
PE = "1"
+PR = "r1"
inherit autotools pkgconfig
@@ -12,6 +13,7 @@ S = "${WORKDIR}/libnl-${PV}"
SRC_URI = "\
http://www.infradead.org/~tgr/libnl/files/libnl-${PV}.tar.gz \
file://fix-pc-file.patch \
+ file://fix-pktloc_syntax_h-race.patch \
"
SRC_URI[md5sum] = "6aaf1e9802a17a7d702bb0638044ffa7"
SRC_URI[sha256sum] = "5a40dc903d3ca1074da7424b908bec8ff16936484798c7e46e53e9db8bc87a9c"
diff --git a/recipes/libnl/libnl2_git.bb b/recipes/libnl/libnl2_git.bb
index 6c5f9f19f5..a04ac3b805 100644
--- a/recipes/libnl/libnl2_git.bb
+++ b/recipes/libnl/libnl2_git.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.infradead.org/~tgr/libnl/"
SRCREV = "d378220c96c3c8b6f27dca33e7d8ba03318f9c2d"
PV = "1.9+gitr${SRCPV}"
PE = "1"
-PR = "r1"
+PR = "r2"
inherit autotools
@@ -14,6 +14,7 @@ includedir = ${prefix}/include/libnl2
SRC_URI = "\
git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git \
file://fix-pc-file.patch \
+ file://fix-pktloc_syntax_h-race.patch \
"
S = "${WORKDIR}/git"