aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-01-09 21:13:01 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-01-09 21:36:05 +0100
commit776fed9f09354d7cbb6568c5a03972e5942b69b6 (patch)
tree694fab3308c99ed3a21c6ba4795b49482deb99a3
parentc5b4df259e8158e6f68f7d144b4bcad9b2eca9c9 (diff)
downloadopenembedded-776fed9f09354d7cbb6568c5a03972e5942b69b6.tar.gz
midori: add git version(fix some Segmentation fault)
Midori had a bug that made it segfault when a link was clicked, before the page was entirely loaded,rendering the browsing experience very difficult(it segfaulted continually under normal browsing activities) Midori developers weren't sure what was the correct fix, but said that it was fixed in their git repository(from #midori on Freenode on irc): Jan 07 22:59:14 <kalikiana> GNUtoo|laptop, that looks like a bug that's fixed in git master [...] Jan 07 23:04:21 <GNUtoo|laptop> what's the bug number? Jan 07 23:04:33 <GNUtoo|laptop> so I could backport the fix's patch Jan 07 23:04:33 <nirik> I don't know off hand I'm afraid. Jan 07 23:04:35 <GNUtoo|laptop> ok Jan 07 23:04:39 <GNUtoo|laptop> what should I look for Jan 07 23:04:39 <GNUtoo|laptop> ? Jan 07 23:05:16 <nirik> possibly: http://git.xfce.org/apps/midori/commit/?id=1f15d17c5fcd6d3ce80a2f3bd5cd00780870fdf5 Jan 07 23:05:32 <GNUtoo|laptop> thanks a lot Jan 07 23:05:37 <MonkeyofDoom> I thought http://git.xfce.org/apps/midori/commit/?id=97a7ae9955d4264f922452d6933f3a0e1e4b03f6 sounded suspect Jan 07 23:05:52 <MonkeyofDoom> but it's also just a possibility Jan 07 23:07:06 <kalikiana> the one MonkeyofDoom mentions is the crasher Jan 07 23:07:19 <kalikiana> the other one is a mis-behaviour of tab opening Jan 07 23:07:26 <GNUtoo|laptop> ok Jan 07 23:07:30 <GNUtoo|laptop> so many possibles crashes Here's was the trace: Program received signal SIGSEGV, Segmentation fault. 0x00000000 in ?? () (gdb) bt #0 0x00000000 in ?? () #1 0x401caef4 in g_object_unref () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #2 0x4116bd34 in webkit_hit_test_result_dispose(_GObject*) () from /home/gnutoo/embedded/sshfs/usr/lib/libwebkitgtk-1.0.so.0 #3 0x401caef4 in g_object_unref () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #4 0x0006414c in midori_view_ensure_link_uri (view=0x22b008, x=0x0, y=0x0) at ../midori/midori-view.c:1630 #5 0x00064210 in gtk_widget_button_press_event_cb (web_view=0x184058, event=0x229910, view=0x22b008) at ../midori/midori-view.c:1653 #6 0x403ecf50 in _gtk_marshal_BOOLEAN__BOXED () from /home/gnutoo/embedded/sshfs/usr/lib/libgtk-x11-2.0.so.0 #7 0x401ca538 in g_closure_invoke () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #8 0x401d2b88 in signal_emit_unlocked_R () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #9 0x401d6c04 in g_signal_emit_valist () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #10 0x401d6db8 in g_signal_emit () from /home/gnutoo/embedded/sshfs/usr/lib/libgobject-2.0.so.0 #11 0x40500914 in gtk_widget_event_internal () from /home/gnutoo/embedded/sshfs/usr/lib/libgtk-x11-2.0.so.0 #12 0x403eb590 in gtk_propagate_event () from /home/gnutoo/embedded/sshfs/usr/lib/libgtk-x11-2.0.so.0 #13 0x403ebae0 in gtk_main_do_event () from /home/gnutoo/embedded/sshfs/usr/lib/libgtk-x11-2.0.so.0 #14 0x40696e60 in gdk_event_dispatch () from /home/gnutoo/embedded/sshfs/usr/lib/libgdk-x11-2.0.so.0 #15 0x40247940 in g_main_context_dispatch () from /home/gnutoo/embedded/sshfs/usr/lib/libglib-2.0.so.0 #16 0x40247dfc in g_main_context_iterate.clone.4 () from /home/gnutoo/embedded/sshfs/usr/lib/libglib-2.0.so.0 #17 0x40248260 in g_main_loop_run () from /home/gnutoo/embedded/sshfs/usr/lib/libglib-2.0.so.0 #18 0x403ea8c8 in gtk_main () from /home/gnutoo/embedded/sshfs/usr/lib/libgtk-x11-2.0.so.0 #19 0x000253cc in main (argc=1, argv=0xbeccece4) at ../midori/main.c:2202 The DEFAULT_PREFERENCE = "-1" is because of that(from #oe on FreeNode on irc): Jan 09 21:04:39 <Jay7> or commit with DP=-1 then post request to ML about promoting to default Jan 09 21:04:48 <GNUtoo|laptop> ok I'll send to ml Jan 09 21:05:14 <GNUtoo|laptop> I push some other stuff that only touch htcdream, and get thoses on ml Jan 09 21:05:15 <hrw> push with dp-1 first Jan 09 21:05:18 <GNUtoo|laptop> ok Jan 09 21:07:11 <GNUtoo|laptop> maybe I put DP -1 for all but not for SHR In other words midori is used by a lot of distros/machines and as it's a git version, it's safer not to affect everyone in the case of a (more) problematic bug. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/gtk-webcore/midori_git.bb28
1 files changed, 15 insertions, 13 deletions
diff --git a/recipes/gtk-webcore/midori_git.bb b/recipes/gtk-webcore/midori_git.bb
index 89182c28b4..4f051321ab 100644
--- a/recipes/gtk-webcore/midori_git.bb
+++ b/recipes/gtk-webcore/midori_git.bb
@@ -1,22 +1,24 @@
require midori.inc
-DEPENDS += "python-native python-docutils-native"
+DEPENDS += "vala-native python-native python-docutils-native"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_shr = "1"
# increment PR every time SRCREV is updated!
-SRCREV = "400139644371c0b675723f9a986ddab4445a8794"
-PR = "r3"
-PV = "0.1.7+${PR}+gitr${SRCPV}"
+SRCREV = "ad2f0066ce969152080cd841ce4cdd0920565409"
+PR = "r0"
+PV = "0.2.9+${PR}+gitr${SRCPV}"
-SRC_URI = "git://git.xfce.org/apps/midori;protocol=git \
- file://waf \
- file://wscript-fix.patch"
+SRC_URI = "git://git.xfce.org/apps/midori;protocol=git"
S = "${WORKDIR}/git"
-
+SRC_URI_append_shr = " file://config \
+"
do_configure() {
- cp -f ${WORKDIR}/waf ${S}/
+ sed -i -e 's:, shell=False::g' wscript
./configure \
--prefix=${prefix} \
--bindir=${bindir} \
@@ -31,10 +33,10 @@ do_configure() {
--infodir=${infodir} \
--mandir=${mandir} \
${EXTRA_OECONF}
-
- sed -i /LINK_CC/d ./_build_/c4che/default.cache.py
- echo "LINK_CC = '${CXX}'" >> ./_build_/c4che/default.cache.py
}
-
+do_install_append_shr() {
+ install -d ${D}${sysconfdir}/xdg/midori
+ install -m 0644 ${WORKDIR}/config ${D}${sysconfdir}/xdg/midori
+}