aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-01-10 17:55:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-10 16:23:25 +0100
commit5057daf836f1ec703fa6343c05fa9ed91cae09d6 (patch)
tree2e7e90f09f55a81c83ec970adde993b2cc81dc5a
parent90765911881e365d93037eb3391f319d14650d29 (diff)
downloadopenembedded-5057daf836f1ec703fa6343c05fa9ed91cae09d6.tar.gz
mesa-7.9.1: change configure.ac to check for python not python2 as python-native does not stage python2
* should we fix it in python recipes instead? maybe more projects are looking for python2 and finds is on host not sysroot Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/mesa/mesa-7.9.1.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/mesa/mesa-7.9.1.inc b/recipes/mesa/mesa-7.9.1.inc
index 48bdd42206..99a1afefac 100644
--- a/recipes/mesa/mesa-7.9.1.inc
+++ b/recipes/mesa/mesa-7.9.1.inc
@@ -9,3 +9,8 @@ SRC_URI[archive.md5sum] = "07dc6cfb5928840b8b9df5bd1b3ae434"
SRC_URI[archive.sha256sum] = "403986cd83d957db17957f11c320c9562cc8675273efbaa402e88bf4e6586721"
EXTRA_OECONF += " --disable-gallium"
+
+do_configure_prepend() {
+ #check for python not python2, because python-native does not stage python2 binary/link
+ sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
+}