aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyal Reizer <eyalreizer@googlemail.com>2011-09-26 21:07:34 +0000
committerDenys Dmytriyenko <denys@ti.com>2011-10-05 17:13:36 -0400
commita8eedede78d442ab7e16db8894d2b5172a1bc8df (patch)
tree78e37f0539bf86fa3865b52812876b319e2428af
parent5477979116e2c93658d827344b6e1aa1c30dfeab (diff)
downloadopenembedded-a8eedede78d442ab7e16db8894d2b5172a1bc8df.tar.gz
iw: build version 0.9.22 from git sources
Builds a new version which adds wowlan support from public git source Signed-off-by: Eyal Reizer <eyalr@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes/iw/iw_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/iw/iw_git.bb b/recipes/iw/iw_git.bb
new file mode 100644
index 0000000000..c98e1bc5f7
--- /dev/null
+++ b/recipes/iw/iw_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nl80211 based CLI configuration utility for wireless devices"
+HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRCREV = "0a236ef5f8e4ba7218aac7d0cdacf45673d5b35c"
+PR = "r0"
+PV = "0.9.22"
+PR_append = "+gitr${SRCPV}"
+
+DEPENDS = "libnl pkgconfig"
+
+SRC_URI = " \
+ git://git.sipsolutions.net/iw.git;protocol=git \
+ "
+CFLAGS += "-DCONFIG_LIBNL20"
+
+S = "${WORKDIR}/git/"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}