aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2011-10-16 22:04:31 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-10-16 22:17:37 +0200
commit63d3969b0f839fc4b7bf7fe836daec729d9d3c53 (patch)
tree74efaa185f74b654a833d1dd0f8152eb9ae02e29
parent1831408cf1949576f5fd1526b8e4fd6a535f9e89 (diff)
downloadopenembedded-63d3969b0f839fc4b7bf7fe836daec729d9d3c53.tar.gz
lightmediascanner: Add version 0.4.4
1. The release announcement [1] has some more information about the current state. 2. The “official” Web site listed also in the recipe is not current anymore because the credentials have been lost. 3. This recipe is tested using `angstrom-2010.x` and `minimal{,-uclibc}` for `MACHINE = "beagleboard"`. [1] http://blog.gustavobarbieri.com.br/2011/08/19/ann-lightmediascanner-0-4-4-released/ Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/lightmediascanner/lightmediascanner_0.4.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/lightmediascanner/lightmediascanner_0.4.4.bb b/recipes/lightmediascanner/lightmediascanner_0.4.4.bb
new file mode 100644
index 0000000000..1d9a61ba91
--- /dev/null
+++ b/recipes/lightmediascanner/lightmediascanner_0.4.4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Lightweight media scanner meant to be used in not-so-powerful devices"
+AUTHOR = "ProFUSION"
+HOMEPAGE = "http://lms.garage.maemo.org/"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "sqlite3 flac virtual/libiconv"
+
+PE = "1"
+PR = "r0"
+
+SRC_URI = "http://git.profusion.mobi/cgit.cgi/lightmediascanner.git/snapshot/release_${PV}.tar.bz2 \
+"
+SRC_URI[md5sum] = "f423376a70f8f321af69b12563b176fe"
+SRC_URI[sha256sum] = "302a7f6cc355467cd20332f4e02c8b87ba6c0c7a6818a6a987e007aace19b41e"
+
+S = "${WORKDIR}/release_${PV}"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}/${bindir}/
+ install -m 755 ${S}/src/bin/.libs/test ${D}/${bindir}/test-lms
+}
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${bindir}/test-lms"
+
+FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug"