aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-31 14:51:55 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-31 14:51:55 +0100
commitbdc1df73305bc2213a065c43f9c215fdf310e794 (patch)
tree48c969704b374dd999f7927207bcd025712153fd
parent91403056b1467560c9452a0def50402b53b16597 (diff)
downloadopenembedded-bdc1df73305bc2213a065c43f9c215fdf310e794.tar.gz
mythtv: added staging
-rw-r--r--recipes/mythtv/mythtv_0.22rc1.bb38
1 files changed, 36 insertions, 2 deletions
diff --git a/recipes/mythtv/mythtv_0.22rc1.bb b/recipes/mythtv/mythtv_0.22rc1.bb
index b7cadb3c4a..8e95d0d99c 100644
--- a/recipes/mythtv/mythtv_0.22rc1.bb
+++ b/recipes/mythtv/mythtv_0.22rc1.bb
@@ -5,7 +5,7 @@ inherit qmake2 qt4x11
DEFAULT_PREFERENCE = "-1"
PV = "0.21+0.22rc1"
-PR = "r2"
+PR = "r3"
REALPV = "0.22"
SRC_URI = "ftp://ftp.osuosl.org/pub/mythtv/mythtv-0.22rc1.tar.bz2"
@@ -51,8 +51,8 @@ EXTRA_OECONF = " \
--cross-prefix=${TARGET_PREFIX} \
--sysroot=${STAGING_DIR_HOST} \
--prefix=${prefix} \
+ --arch=${TARGET_ARCH} \
\
- --arch=${TARGET_ARCH} \
--extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
--extra-cxxflags="${TARGET_CXXFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
--extra-ldflags="${TARGET_LDFLAGS}" \
@@ -87,3 +87,37 @@ python populate_packages_prepend () {
bb.data.setVar("RDEPENDS_${PN}", "%s %s" % (bb.data.getVar("RDEPENDS_${PN}", d), " ".join(new_packages)), d)
}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -d ${STAGING_INCDIR}/${PN}
+ install -d ${STAGING_INCDIR}/${PN}/dvdnav
+ install -d ${STAGING_INCDIR}/${PN}/dvdread
+ install -d ${STAGING_INCDIR}/${PN}/libavcodec
+ install -d ${STAGING_INCDIR}/${PN}/libavformat
+ install -d ${STAGING_INCDIR}/${PN}/libavutil
+ install -d ${STAGING_INCDIR}/${PN}/libmyth
+ install -d ${STAGING_INCDIR}/${PN}/libmythdb
+ install -d ${STAGING_INCDIR}/${PN}/libmythui
+ install -d ${STAGING_INCDIR}/${PN}/libswscale
+ install -d ${STAGING_INCDIR}/${PN}/mpeg2dec
+ install -d ${STAGING_INCDIR}/${PN}/upnp
+ install -m 0644 ${D}/${includedir}/${PN}/*.h ${STAGING_INCDIR}/${PN}
+ install -m 0644 ${D}/${includedir}/${PN}/mythconfig.mak ${STAGING_INCDIR}/${PN}
+ install -m 0644 ${D}/${includedir}/${PN}/dvdnav/*.h ${STAGING_INCDIR}/${PN}/dvdnav
+ install -m 0644 ${D}/${includedir}/${PN}/dvdread/*.h ${STAGING_INCDIR}/${PN}/dvdread
+ install -m 0644 ${D}/${includedir}/${PN}/libavcodec/*.h ${STAGING_INCDIR}/${PN}/libavcodec
+ install -m 0644 ${D}/${includedir}/${PN}/libavformat/*.h ${STAGING_INCDIR}/${PN}/libavformat
+ install -m 0644 ${D}/${includedir}/${PN}/libavutil/*.h ${STAGING_INCDIR}/${PN}/libavutil
+ install -m 0644 ${D}/${includedir}/${PN}/libmyth/*.h ${STAGING_INCDIR}/${PN}/libmyth
+ install -m 0644 ${D}/${includedir}/${PN}/libmythdb/*.h ${STAGING_INCDIR}/${PN}/libmythdb
+ install -m 0644 ${D}/${includedir}/${PN}/libmythui/*.h ${STAGING_INCDIR}/${PN}/libmythui
+ install -m 0644 ${D}/${includedir}/${PN}/libswscale/*.h ${STAGING_INCDIR}/${PN}/libswscale
+ install -m 0644 ${D}/${includedir}/${PN}/mpeg2dec/*.h ${STAGING_INCDIR}/${PN}/mpeg2dec
+ install -m 0644 ${D}/${includedir}/${PN}/upnp/*.h ${STAGING_INCDIR}/${PN}/upnp
+ sed -i 's:LIBDIR=/usr/lib:LIBDIR=${STAGING_LIBDIR}:' ${STAGING_INCDIR}/${PN}/mythconfig.mak
+ # next part may need to be done better
+ cp -R ${D}/${libdir}/* ${STAGING_LIBDIR}
+ # ugly chmod ahead
+ chmod -R ugo+r ${STAGING_LIBDIR}
+}