aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2009-10-29 17:30:35 -0500
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:40:08 +0100
commita355c055c83cda1db901337bafdab9d5bed6a635 (patch)
tree879c55e43fc9f560329d33c11b3ce5492774a9e2
parentee94e37cf85a5050af8c0962134004e2c2861be0 (diff)
downloadopenembedded-a355c055c83cda1db901337bafdab9d5bed6a635.tar.gz
gstreamer-ti svn: bump up svn rev and add boot script
-rw-r--r--recipes/ti/gstreamer-ti/gstreamer-ti-add-omapfb.patch28
-rw-r--r--recipes/ti/gstreamer-ti/gstreamer-ti-omap3530-rc.sh71
-rw-r--r--recipes/ti/gstreamer-ti_svn.bb13
3 files changed, 96 insertions, 16 deletions
diff --git a/recipes/ti/gstreamer-ti/gstreamer-ti-add-omapfb.patch b/recipes/ti/gstreamer-ti/gstreamer-ti-add-omapfb.patch
index 27e1c731f5..7a76f370bc 100644
--- a/recipes/ti/gstreamer-ti/gstreamer-ti-add-omapfb.patch
+++ b/recipes/ti/gstreamer-ti/gstreamer-ti-add-omapfb.patch
@@ -1,6 +1,6 @@
diff -uNr ticodecplugin/configure.ac ticodecplugin.new/configure.ac
--- ticodecplugin/configure.ac 2009-09-05 00:04:51.000000000 -0500
-+++ ticodecplugin.new/configure.ac 2009-10-10 15:50:24.000000000 -0500
++++ ticodecplugin.new/configure.ac 2009-10-28 06:35:20.000000000 -0500
@@ -25,6 +25,7 @@
AC_SUBST(ACLOCAL_AMFLAGS, "-I m4")
@@ -10,14 +10,14 @@ diff -uNr ticodecplugin/configure.ac ticodecplugin.new/configure.ac
dnl check for tools
AC_PROG_CC
diff -uNr ticodecplugin/src/Makefile.am ticodecplugin.new/src/Makefile.am
---- ticodecplugin/src/Makefile.am 2009-10-10 14:27:46.000000000 -0500
-+++ ticodecplugin.new/src/Makefile.am 2009-10-10 15:50:24.000000000 -0500
+--- ticodecplugin/src/Makefile.am 2009-10-28 06:27:14.000000000 -0500
++++ ticodecplugin.new/src/Makefile.am 2009-10-28 06:35:20.000000000 -0500
@@ -4,16 +4,16 @@
plugin_LTLIBRARIES = libgstticodecplugin.la
# sources used to compile this plug-in
--libgstticodecplugin_la_SOURCES = gstticodecplugin.c gsttiauddec.c gsttiauddec1.c gsttividdec.c gsttividdec2.c gsttiimgenc1.c gsttiimgenc.c gsttiimgdec1.c gsttiimgdec.c gsttidmaibuffertransport.c gstticircbuffer.c gsttidmaivideosink.c gstticodecs.c gstticodecs_platform.c gsttiquicktime_aac.c gsttiquicktime_h264.c gsttividenc.c gsttividenc1.c gsttiaudenc1.c gstticommonutils.c gsttividresize.c
-+libgstticodecplugin_la_SOURCES = gstticodecplugin.c gsttiauddec.c gsttiauddec1.c gsttividdec.c gsttividdec2.c gsttiimgenc1.c gsttiimgenc.c gsttiimgdec1.c gsttiimgdec.c gsttidmaibuffertransport.c gstticircbuffer.c gsttidmaivideosink.c gstticodecs.c gstticodecs_platform.c gsttiquicktime_aac.c gsttiquicktime_h264.c gsttividenc.c gsttividenc1.c gsttiaudenc1.c gstticommonutils.c gsttividresize.c omapfb.c yuv.S
+-libgstticodecplugin_la_SOURCES = gstticodecplugin.c gsttiauddec.c gsttiauddec1.c gsttividdec.c gsttividdec2.c gsttiimgenc1.c gsttiimgenc.c gsttiimgdec1.c gsttiimgdec.c gsttidmaibuffertransport.c gstticircbuffer.c gsttidmaivideosink.c gstticodecs.c gstticodecs_platform.c gsttiquicktime_aac.c gsttiquicktime_h264.c gsttividenc.c gsttividenc1.c gsttiaudenc1.c gstticommonutils.c gsttividresize.c gsttidmaiperf.c
++libgstticodecplugin_la_SOURCES = gstticodecplugin.c gsttiauddec.c gsttiauddec1.c gsttividdec.c gsttividdec2.c gsttiimgenc1.c gsttiimgenc.c gsttiimgdec1.c gsttiimgdec.c gsttidmaibuffertransport.c gstticircbuffer.c gsttidmaivideosink.c gstticodecs.c gstticodecs_platform.c gsttiquicktime_aac.c gsttiquicktime_h264.c gsttividenc.c gsttividenc1.c gsttiaudenc1.c gstticommonutils.c gsttividresize.c gsttidmaiperf.c omapfb.c yuv.S
# flags used to compile this plugin
# add other _CFLAGS and _LIBS as needed
@@ -34,18 +34,18 @@ diff -uNr ticodecplugin/src/Makefile.am ticodecplugin.new/src/Makefile.am
# XDC Configuration
CONFIGURO = $(XDC_INSTALL_DIR)/xs xdc.tools.configuro
diff -uNr ticodecplugin/src/gstticodecplugin.c ticodecplugin.new/src/gstticodecplugin.c
---- ticodecplugin/src/gstticodecplugin.c 2009-10-10 14:27:46.000000000 -0500
-+++ ticodecplugin.new/src/gstticodecplugin.c 2009-10-10 15:52:51.000000000 -0500
-@@ -46,6 +46,7 @@
- #include "gsttividenc1.h"
+--- ticodecplugin/src/gstticodecplugin.c 2009-10-28 06:27:14.000000000 -0500
++++ ticodecplugin.new/src/gstticodecplugin.c 2009-10-28 06:36:28.000000000 -0500
+@@ -47,6 +47,7 @@
#include "gsttiaudenc1.h"
#include "gsttividresize.h"
+ #include "gsttidmaiperf.h"
+#include "omapfb.h"
/* entry point to initialize the plug-in
* initialize the plug-in itself
-@@ -153,6 +154,13 @@
- GST_TYPE_TIVIDRESIZE))
+@@ -161,6 +162,13 @@
+ GST_TYPE_DMAIPERF))
return FALSE;
+ env_value = getenv("GST_omapdmaifbsink_DISABLE");
@@ -60,7 +60,7 @@ diff -uNr ticodecplugin/src/gstticodecplugin.c ticodecplugin.new/src/gstticodecp
diff -uNr ticodecplugin/src/omapfb.c ticodecplugin.new/src/omapfb.c
--- ticodecplugin/src/omapfb.c 1969-12-31 18:00:00.000000000 -0600
-+++ ticodecplugin.new/src/omapfb.c 2009-10-10 15:50:24.000000000 -0500
++++ ticodecplugin.new/src/omapfb.c 2009-10-28 06:35:20.000000000 -0500
@@ -0,0 +1,1005 @@
+/*
+ * Copyright (C) 2008 Felipe Contreras <felipe.contreras@gmail.com>
@@ -1069,7 +1069,7 @@ diff -uNr ticodecplugin/src/omapfb.c ticodecplugin.new/src/omapfb.c
+}
diff -uNr ticodecplugin/src/omapfb.h ticodecplugin.new/src/omapfb.h
--- ticodecplugin/src/omapfb.h 1969-12-31 18:00:00.000000000 -0600
-+++ ticodecplugin.new/src/omapfb.h 2009-10-10 15:50:24.000000000 -0500
++++ ticodecplugin.new/src/omapfb.h 2009-10-28 06:35:20.000000000 -0500
@@ -0,0 +1,142 @@
+/*
+ * Copyright (C) 2008 Felipe Contreras <felipe.contreras@gmail.com>
@@ -1215,7 +1215,7 @@ diff -uNr ticodecplugin/src/omapfb.h ticodecplugin.new/src/omapfb.h
+#endif /* GST_OMAPFB_H */
diff -uNr ticodecplugin/src/yuv.S ticodecplugin.new/src/yuv.S
--- ticodecplugin/src/yuv.S 1969-12-31 18:00:00.000000000 -0600
-+++ ticodecplugin.new/src/yuv.S 2009-10-10 15:50:24.000000000 -0500
++++ ticodecplugin.new/src/yuv.S 2009-10-28 06:35:20.000000000 -0500
@@ -0,0 +1,117 @@
+/*
+ Copyright (C) 2008 Mans Rullgard
diff --git a/recipes/ti/gstreamer-ti/gstreamer-ti-omap3530-rc.sh b/recipes/ti/gstreamer-ti/gstreamer-ti-omap3530-rc.sh
new file mode 100644
index 0000000000..9a19cf926b
--- /dev/null
+++ b/recipes/ti/gstreamer-ti/gstreamer-ti-omap3530-rc.sh
@@ -0,0 +1,71 @@
+#!/bin/sh
+#
+# configure kernel modules for TI DSP based gstreamer plugin
+#
+# Default Memory Map
+#
+# Start Addr Size Description
+# -------------------------------------------
+# 0x80000000 99 MB Linux
+# 0x86300000 16 MB CMEM
+# 0x87300000 13 MB CODEC SERVER
+#
+
+# Disable XDM 0.9 elements
+export GST_TI_TIViddec_DISABLED=1
+export GST_TI_TIAuddec_DISABLED=1
+export GST_TI_TIVidenc_DISABLED=1
+export GST_TI_TIImgdec_DISABLED=1
+export GST_TI_TIImgenc_DISABLED=1
+
+load_module() {
+ #
+ # CMEM Allocation
+ # 1x5250000 Circular buffer
+ # 6x829440,1x691200 Video buffers (max D1 PAL)
+ # 1x345600 Underlying software components (codecs, etc.)
+ # 1x1 Dummy buffer used during final flush
+ modprobe cmemk allowOverlap=1 phys_start=0x86300000 phys_end=0x87300000 \
+ pools=1x5250000,6x829440,1x345600,1x691200,1x1
+
+ # insert DSP/BIOS Link driver
+ modprobe dsplinkk
+
+ # insert Local Power Manager driver
+ modprobe lpm_omap3530
+
+ # insert SDMA driver
+ modprobe sdmak
+}
+
+unload_module() {
+ rmmod cmemk
+ rmmod lpm_omap3530
+ rmmod dsplinkk
+ rmmod sdmak
+}
+
+case "$1" in
+ start)
+ echo -n "Loading kernel modules for gstreamer-ti... "
+ load_module
+ echo " done"
+ ;;
+ stop)
+ echo -n "Unloading kernel module ..."
+ unload_module
+ echo " done"
+ ;;
+ restart)
+ echo -n "Unloading kernel module ..."
+ unload_module
+ echo " done"
+ echo -n "Loading kernel modules for gstreamer-ti... "
+ load_module
+ echo " done"
+ ;;
+ *)
+ echo "$0 <start/stop/restart>"
+ ;;
+esac
+
diff --git a/recipes/ti/gstreamer-ti_svn.bb b/recipes/ti/gstreamer-ti_svn.bb
index a916bae749..099ca1d91b 100644
--- a/recipes/ti/gstreamer-ti_svn.bb
+++ b/recipes/ti/gstreamer-ti_svn.bb
@@ -2,15 +2,19 @@ DESCRIPTION = "Gstreamer plugin for TI Davinci and OMAP processors"
require ti-paths.inc
+inherit update-rc.d
inherit autotools
DEPENDS = "ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly"
+GST_TI_RC_SCRIPT_armv7a="gstreamer-ti-omap3530-rc.sh"
+
# Fetch source from svn repo
-SRCREV = "407"
+SRCREV = "459"
SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https;user=anonymous;pswd='' \
file://gstreamer-ti-tracker-462.patch;patch=1 \
file://gstreamer-ti-remove-mp3-decode-support-from-auddec1.patch;patch=1 \
+ file://${GST_TI_RC_SCRIPT} \
"
SRC_URI_append_armv7a = " \
@@ -22,6 +26,8 @@ PR = "r37"
PV = "svnr${SRCREV}"
S = "${WORKDIR}/gstreamer_ti/ti_build/ticodecplugin"
+INITSCRIPT_NAME = "gstti-init"
+INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
XDC_TARGET = gnu.targets.arm.GCArmv5T
XDC_PLATFORM_dm6446-evm = ti.platforms.evmDM6446
@@ -58,6 +64,9 @@ do_install_prepend () {
echo "modprobe sdmak" >> ${D}/${installdir}/gst/${PLATFORM}/loadmodules.sh
fi
chmod 0755 ${D}/${installdir}/gst -R
+
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/${GST_TI_RC_SCRIPT} ${D}${sysconfdir}/init.d/gstti-init
}
pkg_postinst_gstreamer-ti-demo-script () {
@@ -75,7 +84,7 @@ gst-plugins-bad-meta \
gst-plugins-ugly-meta \
ti-dmai-apps"
-FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so ${sysconfdir}"
FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-0.10/*.la"
FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"