aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2009-10-29 17:41:18 -0500
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:40:09 +0100
commit239ca8ddd9786e9d546183b7902e9ac3a96e4057 (patch)
treef64b47a4bdbfd444bbf6b76388edf317c711cf61
parenta355c055c83cda1db901337bafdab9d5bed6a635 (diff)
downloadopenembedded-239ca8ddd9786e9d546183b7902e9ac3a96e4057.tar.gz
bc-cat-omap 0.1.0: add recipe to build bc-cat module.
* adjust libgles-omap3 staging to stage more headers for thisi * bc-cat module complains about unresolved symbols during modprobe hence using modprobe -f to force the module loading.
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/powervr-drivers/bc-cat-omap3-module/rc.bccat22
-rw-r--r--recipes/powervr-drivers/bc-cat-omap3-module_0.1.0.bb2
-rw-r--r--recipes/powervr-drivers/bc-cat.inc51
-rw-r--r--recipes/powervr-drivers/libgles-omap3.inc3
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb2
6 files changed, 83 insertions, 1 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index f20b9da5c0..e5d00d37cd 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -30590,3 +30590,7 @@ sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
md5=5f7b88ebb2bcd7e8044328482d079661
sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
+[http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/OMAP35x_AM35x_Video_Texture_Streaming/1_0/exports/bc-cat-0.1.0.tar.gz]
+md5=c7fdd6041ca823ebe95d1a6b1da12ba7
+sha256=daa948e966ba3aec698e45987e85fa6e1c3b3f54b55f117573c9e0f206d02c92
+
diff --git a/recipes/powervr-drivers/bc-cat-omap3-module/rc.bccat b/recipes/powervr-drivers/bc-cat-omap3-module/rc.bccat
new file mode 100644
index 0000000000..eeb3fdc141
--- /dev/null
+++ b/recipes/powervr-drivers/bc-cat-omap3-module/rc.bccat
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# install bc-cat module and create device nodes
+#
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+case "$1" in
+ start) echo -n "install bc-cat kernel module... "
+ modprobe -f bc-cat
+ rm -rf /dev/bc_cat
+ mknod /dev/bc_cat c `awk "\\$2==\"bc_cat\" {print \\$1}" /proc/devices` 0
+ echo "done"
+ ;;
+ stop) echo -n "removing bc-cat kernel module... "
+ rmmod bc-cat
+ echo "done"
+ rm -rf /dev/bc_cat
+ ;;
+ *) echo "$0 <start/stop>"
+ ;;
+esac
+
diff --git a/recipes/powervr-drivers/bc-cat-omap3-module_0.1.0.bb b/recipes/powervr-drivers/bc-cat-omap3-module_0.1.0.bb
new file mode 100644
index 0000000000..7f5cc70b5d
--- /dev/null
+++ b/recipes/powervr-drivers/bc-cat-omap3-module_0.1.0.bb
@@ -0,0 +1,2 @@
+require bc-cat.inc
+
diff --git a/recipes/powervr-drivers/bc-cat.inc b/recipes/powervr-drivers/bc-cat.inc
new file mode 100644
index 0000000000..4213113393
--- /dev/null
+++ b/recipes/powervr-drivers/bc-cat.inc
@@ -0,0 +1,51 @@
+DESCRIPTION = "Video texture streaming via IMG 3rdparty bufferclass (bc-cat) module"
+DEPENDS = "libgles-omap3"
+inherit module
+
+SRC_URI="http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/OMAP35x_AM35x_Video_Texture_Streaming/1_0/exports/bc-cat-${PV}.tar.gz \
+ file://rc.bccat \
+"
+
+S=${WORKDIR}/bc-cat-${PV}
+
+PACKAGES += " ${PN}-tests"
+INSANE_SKIP_${PN}-tests = True
+INSANE_SKIP_${PN} = True
+FILES_${PN} = "${sysconfdir} /lib/modules/${KERNEL_VERSION}/drivers/gpu/bc-cat/bc_cat.ko"
+FILES_${PN}-tests = "/usr/demos/bc-cat/*"
+RDEPENDS_${PN}-tests += "${PN}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "bccat-init"
+INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
+
+do_compile () {
+ # build kernel module
+ cd ${S}/module
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ make GSDK_KM_DIR=${STAGING_INCDIR} \
+ KERNEL_DIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX}
+
+ # build test application
+ cd ${S}/test
+ make GSDK_KM_DIR=${STAGING_INCDIR} \
+ KERNEL_DIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ X11BUILD=1
+}
+
+do_install () {
+ # install kernel module
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/drivers/gpu/bc-cat
+ cp ${S}/module/bc_cat.ko ${D}/lib/modules/${KERNEL_VERSION}/drivers/gpu/bc-cat
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/rc.bccat ${D}${sysconfdir}/init.d/bccat-init
+
+ # install test app
+ install -d ${D}/usr/demos/bc-cat
+ cp ${S}/test/gles1_bc_mmap ${D}/usr/demos/bc-cat/
+ cp ${S}/test/gles1_bc_webcam ${D}/usr/demos/bc-cat/
+}
+
diff --git a/recipes/powervr-drivers/libgles-omap3.inc b/recipes/powervr-drivers/libgles-omap3.inc
index 23c084c207..880732ad98 100644
--- a/recipes/powervr-drivers/libgles-omap3.inc
+++ b/recipes/powervr-drivers/libgles-omap3.inc
@@ -129,6 +129,9 @@ do_stage () {
cp -pP ${BINLOCATION}/*.a ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}
+ cp -pPR ${S}/GFX_Linux_KM/include4 ${STAGING_INCDIR}/
+ cp -pPR ${S}/GFX_Linux_KM/services4 ${STAGING_INCDIR}/
+
cp -pPR ${S}/GFX_Linux_SDK/OGLES2/SDKPackage/Builds/OGLES2/Include/* ${STAGING_INCDIR}/
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/Include/* ${STAGING_INCDIR}/
cp -pPR ${S}/GFX_Linux_SDK/OGLES/SDKPackage/Builds/OGLES/LinuxOMAP3/Include/GLES/* ${STAGING_INCDIR}/GLES/
diff --git a/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
index 3a90c4e68a..8b51813389 100644
--- a/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
+++ b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
@@ -4,7 +4,7 @@ DEFAULT_PREFERENCE = "1"
# download required binary distribution from:
# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_00_00_09.bin
-PR = "r1"
+PR = "r2"
SGXPV = "3_00_00_09"
IMGPV = "1.3.13.1832"