aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-02 08:19:57 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-02 09:42:44 -0700
commitdd1762e8c7b71d11a49ed59b78bcb454b3b34c36 (patch)
tree2c44f4eb73467352fda3dc1d893a26320e80910f
parentf1b833094610e7b698ec9ec308927e64149f2e23 (diff)
downloadopenembedded-dd1762e8c7b71d11a49ed59b78bcb454b3b34c36.tar.gz
help2man: Update for using our perl-native
Now that we have perl-native going early, we want to wait for it to be done, along with autoconf/automake. But that's just race prevention as we still don't want to re-run autoconf. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/help2man/help2man_1.36.4.bb10
-rw-r--r--recipes/help2man/help2man_1.38.2.bb9
2 files changed, 11 insertions, 8 deletions
diff --git a/recipes/help2man/help2man_1.36.4.bb b/recipes/help2man/help2man_1.36.4.bb
index 138ae4f019..8cb5530c7a 100644
--- a/recipes/help2man/help2man_1.36.4.bb
+++ b/recipes/help2man/help2man_1.36.4.bb
@@ -3,19 +3,21 @@ HOMEPAGE = "http://www.gnu.org/software/help2man"
SECTION = "console/utils"
LICENSE = "GPLv2"
DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
+DEPENDS_virtclass-native = "perl-native autoconf-native automake-native"
RDEPENDS_${PN} = "gettext perl liblocale-gettext-perl"
TARGET_CC_ARCH += "${LDFLAGS}"
-SRC_URI = "${GNU_MIRROR}/help2man/${P}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
inherit autotools
-PR = "r2"
+BBCLASSEXTEND = "native"
-EXTRA_OECONF += "PERL=/usr/bin/perl"
+PR = "r3"
-do_configure () {
+# We don't want to reconfigure things
+do_configure() {
oe_runconf
}
diff --git a/recipes/help2man/help2man_1.38.2.bb b/recipes/help2man/help2man_1.38.2.bb
index 72793362aa..cb1deb3199 100644
--- a/recipes/help2man/help2man_1.38.2.bb
+++ b/recipes/help2man/help2man_1.38.2.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Program to create simple man pages"
SECTION = "devel"
LICENSE = "GPLv3"
DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
-DEPENDS_virtclass-native = ""
-RDEPENDS_pn-help2man = "gettext perl liblocale-gettext-perl"
-PR = "r1"
+DEPENDS_virtclass-native = "perl-native autoconf-native automake-native"
+RDEPENDS_${PN} = "gettext perl liblocale-gettext-perl"
+PR = "r2"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
+
SRC_URI[md5sum] = "426671c6fe79e5ef2233303367eab5a6"
SRC_URI[sha256sum] = "952c29561bce8b233aa10af7f0e0c79c8243712810bf8ddf01e6efd82ce250d1"
@@ -16,7 +17,7 @@ EXTRA_OECONF = "--disable-nls"
BBCLASSEXTEND = "native"
-# We don't want to reconfigure things as we're using host perl
+# We don't want to reconfigure things
do_configure() {
oe_runconf
}