aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-27 10:24:52 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-01 10:51:05 -0700
commit49362da57224282f2dff462afa2e7ba9519ad7b5 (patch)
tree766ad7d3f373fcb0498217f340922c4c03c2bc48
parentc15142c5e3c5556e7a9d534e8b0a5aa175b79a3a (diff)
downloadopenembedded-49362da57224282f2dff462afa2e7ba9519ad7b5.tar.gz
perl-native: Switch to userelocatableinc and not shared libperl
While in here, we didn't use db nor gdbm so remove those as deps. This recipe is safe with no other deps so add INHIBIT_DEFAULT_DEPS and switch to patch as PATCHTOOL. Being relocatable means we don't need the config.sh mangling we had been doing and we want to be more clear about our mangling of scripts to use /usr/bin/env perl Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/perl/perl-native_5.10.1.bb32
1 files changed, 15 insertions, 17 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index c1743b7b05..35cd3c0f81 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -2,9 +2,10 @@ DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
-DEPENDS = "virtual/db-native gdbm-native"
-PR = "r8"
+PR = "r9"
NATIVE_INSTALL_WORKS = "1"
+INHIBIT_DEFAULT_DEPS = "1"
+PATCHTOOL = "patch"
# 5.10.1 has this module built-in
PROVIDES += "libmodule-build-perl-native"
@@ -34,19 +35,21 @@ do_configure () {
-Dcflags="${CFLAGS}" \
-Dldflags="${LDFLAGS}" \
-Dcf_by="Open Embedded" \
+ \
-Dprefix=${prefix} \
-Dvendorprefix=${prefix} \
-Dvendorprefix=${prefix} \
-Dsiteprefix=${prefix} \
+ \
+ -Dprivlib=.../../lib/perl/${PV} \
+ -Darchlib=.../../lib/perl/${PV} \
+ -Dvendorlib=.../../lib/perl/${PV} \
+ -Dvendorarch=.../../lib/perl/${PV} \
+ -Dsitelib=.../../lib/perl/${PV} \
+ -Dsitearch=.../../lib/perl/${PV} \
+ -Duserelocatableinc="y" \
\
- -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
- -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
- \
- -Duseshrplib \
+ -Uuseshrplib \
-Dusethreads \
-Duseithreads \
-Duselargefiles \
@@ -63,11 +66,6 @@ do_configure () {
-Ud_csh \
-Uusesfio \
-Uusenm -des
- sed "s!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
- s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!;
- s!^installbin=.*!installbin=\'${STAGING_BINDIR}\'!;
- s!^installsitebin=.*!installsitebin=\'${STAGING_BINDIR}\'!" < config.sh > config.sh.new
- mv config.sh.new config.sh
}
do_install() {
@@ -103,8 +101,8 @@ do_install() {
sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm
# Make sure we use /usr/bin/env perl
- for PERLSCRIPT in `grep -rIl ${bindir}/perl ${D}${bindir}`; do
- sed -i -e 's|^#!${bindir}/perl|#!/usr/bin/env perl|' $PERLSCRIPT
+ for PERLSCRIPT in `grep -rIEl '#!.*/perl' ${D}${bindir}`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env perl|' $PERLSCRIPT
done
}