aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-25 22:52:03 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-28 16:17:16 +0200
commitff87a2a765ae6445bedd4d2fda9bdcccc689da64 (patch)
tree0bee637a653610e05ac561a77684b904c435d1ea
parentd3bfa68c288ac9de5981af949e3120ad5535eb97 (diff)
downloadopenembedded-ff87a2a765ae6445bedd4d2fda9bdcccc689da64.tar.gz
python-pyside-embedded: update patch for qws support and bump PR
This removes the binding for the QWSServer from the patch as it's not working and not needed anymore. Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/pyside/python-pyside-embedded/support-qws.patch18
-rw-r--r--recipes/pyside/python-pyside-embedded_1.0.2.bb2
2 files changed, 14 insertions, 6 deletions
diff --git a/recipes/pyside/python-pyside-embedded/support-qws.patch b/recipes/pyside/python-pyside-embedded/support-qws.patch
index 299109a38b..1070a2785d 100644
--- a/recipes/pyside/python-pyside-embedded/support-qws.patch
+++ b/recipes/pyside/python-pyside-embedded/support-qws.patch
@@ -1,19 +1,28 @@
diff -Naur pyside-qt4.7+1.0.2-orig/CMakeLists.txt pyside-qt4.7+1.0.2/CMakeLists.txt
--- pyside-qt4.7+1.0.2-orig/CMakeLists.txt 2011-04-28 22:43:01.000000000 +0200
-+++ pyside-qt4.7+1.0.2/CMakeLists.txt 2011-05-11 11:21:17.826916001 +0200
-@@ -105,6 +105,8 @@
++++ pyside-qt4.7+1.0.2/CMakeLists.txt 2011-05-21 22:49:28.043397002 +0200
+@@ -89,6 +89,7 @@
+ set(ENABLE_MAC "0")
+ set(ENABLE_WIN "0")
+ set(ENABLE_SIMULATOR "0")
++set(ENABLE_QWS "0")
+ if(Q_WS_X11)
+ set(ENABLE_X11 "1")
+ if(Q_WS_MAEMO_5)
+@@ -105,6 +106,9 @@
elseif(Q_WS_SIMULATOR)
set(ENABLE_SIMULATOR "1")
set(AUTO_OS "simulator")
+elseif(Q_WS_QWS)
++ set(ENABLE_QWS "1")
+ set(AUTO_OS "qws")
else()
message(FATAL_ERROR "OS not supported")
endif()
diff -Naur pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml
--- pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml 1970-01-01 01:00:00.000000000 +0100
-+++ pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml 2011-05-11 11:22:45.246916001 +0200
-@@ -0,0 +1,23 @@
++++ pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml 2011-05-25 23:02:02.830307000 +0200
+@@ -0,0 +1,22 @@
+<?xml version="1.0"?>
+<!--
+ This file is part of PySide project.
@@ -35,5 +44,4 @@ diff -Naur pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml pyside-qt
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+-->
+<typesystem package="PySide.QtGui">
-+ <object-type name="QWSServer"/>
+</typesystem>
diff --git a/recipes/pyside/python-pyside-embedded_1.0.2.bb b/recipes/pyside/python-pyside-embedded_1.0.2.bb
index 3566799d69..a684c8336f 100644
--- a/recipes/pyside/python-pyside-embedded_1.0.2.bb
+++ b/recipes/pyside/python-pyside-embedded_1.0.2.bb
@@ -1,7 +1,7 @@
inherit qt4e
require python-pyside.inc
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI += " \
file://no-accessibility-support.patch \
file://support-qws.patch \