aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-05-31 08:56:21 -0700
committerTom Rini <tom_rini@mentor.com>2011-05-31 08:57:13 -0700
commitd61ba0ce8fa482ab2ee3713b0691fb83ff9e03d4 (patch)
tree431972d178be60b90ee057d86da5f0360d6f542e
parentcc0e53de68376fb1987e0a11cd977e481cd7d95d (diff)
downloadopenembedded-d61ba0ce8fa482ab2ee3713b0691fb83ff9e03d4.tar.gz
iproute2: Add 2.6.38 version
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/iproute2/iproute2-2.6.38/configure-cross.patch58
-rw-r--r--recipes/iproute2/iproute2_2.6.38.bb20
2 files changed, 78 insertions, 0 deletions
diff --git a/recipes/iproute2/iproute2-2.6.38/configure-cross.patch b/recipes/iproute2/iproute2-2.6.38/configure-cross.patch
new file mode 100644
index 0000000000..631d6bf958
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.38/configure-cross.patch
@@ -0,0 +1,58 @@
+Index: iproute2-2.6.34/configure
+===================================================================
+--- iproute2-2.6.34.orig/configure
++++ iproute2-2.6.34/configure
+@@ -4,7 +4,7 @@
+ INCLUDE=${1:-"$PWD/include"}
+
+ TABLES=
+-
++SYSROOT=$1
+ check_atm()
+ {
+ cat >/tmp/atmtest.c <<EOF
+@@ -15,7 +15,7 @@ int main(int argc, char **argv) {
+ return 0;
+ }
+ EOF
+-gcc -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
++$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+ echo "TC_CONFIG_ATM:=y" >>Config
+@@ -49,7 +49,7 @@ int main(int argc, char **argv)
+
+ EOF
+
+-if gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
++if $CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
+ then
+ echo "TC_CONFIG_XT:=y" >>Config
+ echo "using xtables"
+@@ -86,7 +86,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -126,7 +126,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -150,7 +150,7 @@ check_ipt()
+ check_ipt_lib_dir()
+ {
+ IPT_LIB_DIR=""
+- for dir in /lib /usr/lib /usr/local/lib
++ for dir in $SYSROOT/lib $SYSROOT/usr/lib $SYSROOT/usr/local/lib
+ do
+ for file in $dir/$TABLES/lib*t_*so ; do
+ if [ -f $file ]; then
diff --git a/recipes/iproute2/iproute2_2.6.38.bb b/recipes/iproute2/iproute2_2.6.38.bb
new file mode 100644
index 0000000000..6a72999d15
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.38.bb
@@ -0,0 +1,20 @@
+require iproute2.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}.tar.bz2 \
+ file://configure-cross.patch \
+ "
+
+SRC_URI[md5sum] = "a243bfea837e71824b7ca26c3bb45fa8"
+SRC_URI[sha256sum] = "47629a4f547f21d94d8e823a87dd8e13042cadecefea2e2dc433e4134fa9aec4"
+
+S = "${WORKDIR}/iproute2-${PV}"
+
+do_configure () {
+ ./configure ${STAGING_DIR_TARGET}
+}
+
+do_install_append() {
+ install -m 0755 tc/tc ${D}${base_sbindir}
+}