aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-28 10:03:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-29 10:50:39 +0200
commitd4f0211e2078d5033ae0dee74664de5520d8392d (patch)
tree29f25043107fe81392f39e6e3b93eb8673c9a209
parent35d66e346fa579f31c94083322cb4367b5a9cad3 (diff)
downloadopenembedded-d4f0211e2078d5033ae0dee74664de5520d8392d.tar.gz
qt4: remove qte.sh from shared SRC_URI and PACKAGE_ARCH_palmpre
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/qt4/qt-4.6.3.inc3
-rw-r--r--recipes/qt4/qt-4.7.3.inc3
-rw-r--r--recipes/qt4/qt4-embedded.inc3
-rw-r--r--recipes/qt4/qt4-embedded_4.6.3.bb4
-rw-r--r--recipes/qt4/qt4-embedded_4.7.3.bb4
5 files changed, 8 insertions, 9 deletions
diff --git a/recipes/qt4/qt-4.6.3.inc b/recipes/qt4/qt-4.6.3.inc
index a35d57aedd..36c6a56b4b 100644
--- a/recipes/qt4/qt-4.6.3.inc
+++ b/recipes/qt4/qt-4.6.3.inc
@@ -19,9 +19,6 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://linux.conf \
"
-# Set necessary variables in the profile
-SRC_URI += "file://qte.sh"
-
S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
do_configure_prepend() {
diff --git a/recipes/qt4/qt-4.7.3.inc b/recipes/qt4/qt-4.7.3.inc
index 2450144904..b29d892515 100644
--- a/recipes/qt4/qt-4.7.3.inc
+++ b/recipes/qt4/qt-4.7.3.inc
@@ -16,9 +16,6 @@ SRC_URI = "\
file://linux.conf \
"
-# Set necessary variables in the profile
-SRC_URI += "file://qte.sh"
-
S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
FILES_${QT_BASE_NAME}-tools += "${bindir}/qml"
diff --git a/recipes/qt4/qt4-embedded.inc b/recipes/qt4/qt4-embedded.inc
index 147126d7ae..168a8677e8 100644
--- a/recipes/qt4/qt4-embedded.inc
+++ b/recipes/qt4/qt4-embedded.inc
@@ -28,9 +28,6 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${
# Set necessary variables in the profile
SRC_URI += "file://qte.sh"
-# For the palmpre we ship a modified qte.sh
-PACKAGE_ARCH_palmpre = "${MACHINE_ARCH}"
-
S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
QT_CONFIG_FLAGS += " \
diff --git a/recipes/qt4/qt4-embedded_4.6.3.bb b/recipes/qt4/qt4-embedded_4.6.3.bb
index fe49fdba8f..8c883f54a8 100644
--- a/recipes/qt4/qt4-embedded_4.6.3.bb
+++ b/recipes/qt4/qt4-embedded_4.6.3.bb
@@ -5,3 +5,7 @@ PR = "${INC_PR}.2"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
require qt-${PV}.inc
+
+# SRC_URI from qt4-embedded.inc was replaced in .inc above and qte.sh lost
+# Set necessary variables in the profile
+SRC_URI += "file://qte.sh"
diff --git a/recipes/qt4/qt4-embedded_4.7.3.bb b/recipes/qt4/qt4-embedded_4.7.3.bb
index 7e3d4b8325..47176a9c0b 100644
--- a/recipes/qt4/qt4-embedded_4.7.3.bb
+++ b/recipes/qt4/qt4-embedded_4.7.3.bb
@@ -8,6 +8,10 @@ QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
require qt-${PV}.inc
+# SRC_URI from qt4-embedded.inc was replaced in .inc above and qte.sh lost
+# Set necessary variables in the profile
+SRC_URI += "file://qte.sh"
+
QT_CONFIG_FLAGS += " \
-exceptions \
"