aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-05-31 13:00:59 -0700
committerTom Rini <tom_rini@mentor.com>2011-05-31 13:30:00 -0700
commit1a1f68d70af9054d8e8216c02f5debf83c1544b0 (patch)
treec9db6be0ea064d26f11ae65bbf52aa23a8206dc8
parent9e2ffc85de9367da27865f5b40b725035b97b24c (diff)
downloadopenembedded-1a1f68d70af9054d8e8216c02f5debf83c1544b0.tar.gz
lmbench: Obey ranlib
In some cases the host may have too old of a ranlib to work. Since it's not exactly a great idea to not be using the cross ranlib anyhow, fix the Makefile so we can override ranlib and then override it. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/lmbench/lmbench-3.0-a9/obey-ranlib.patch25
-rw-r--r--recipes/lmbench/lmbench_3.0-a9.bb7
2 files changed, 29 insertions, 3 deletions
diff --git a/recipes/lmbench/lmbench-3.0-a9/obey-ranlib.patch b/recipes/lmbench/lmbench-3.0-a9/obey-ranlib.patch
new file mode 100644
index 0000000000..5ce6e15a63
--- /dev/null
+++ b/recipes/lmbench/lmbench-3.0-a9/obey-ranlib.patch
@@ -0,0 +1,25 @@
+---
+ src/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+Index: lmbench-3.0-a9/src/Makefile
+===================================================================
+--- lmbench-3.0-a9.orig/src/Makefile
++++ lmbench-3.0-a9/src/Makefile
+@@ -38,6 +38,7 @@ CC=`../scripts/compiler`
+ MAKE=`../scripts/make`
+ AR=ar
+ ARCREATE=cr
++RANLIB=ranlib
+
+ # base of installation location
+ BASE=/usr/local
+@@ -217,7 +218,7 @@ $O/lmbench : ../scripts/lmbench version.
+ $O/lmbench.a: $(LIBOBJS)
+ /bin/rm -f $O/lmbench.a
+ $(AR) $(ARCREATE) $O/lmbench.a $(LIBOBJS)
+- -ranlib $O/lmbench.a
++ -$(RANLIB) $O/lmbench.a
+
+ $O/lib_timing.o : lib_timing.c $(INCS)
+ $(COMPILE) -c lib_timing.c -o $O/lib_timing.o
diff --git a/recipes/lmbench/lmbench_3.0-a9.bb b/recipes/lmbench/lmbench_3.0-a9.bb
index ce6d1a80c0..e84ab475c7 100644
--- a/recipes/lmbench/lmbench_3.0-a9.bb
+++ b/recipes/lmbench/lmbench_3.0-a9.bb
@@ -3,20 +3,21 @@ DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r4"
+PR = "r5"
inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://lmbench-run \
file://rename-line-binary.patch \
- file://update-results-script.patch"
+ file://update-results-script.patch \
+ file://obey-ranlib.patch"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
S = "${WORKDIR}/lmbench-${PV}"
-EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" CFLAGS="${CFLAGS}" \
+EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB} CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
TARGET="${TARGET_OS}" BASE="${prefix}"'