aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-11 20:07:30 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-11 20:07:30 -0700
commitc711c4c6556bb8744023f3e44edffafc2d2fbfac (patch)
tree58d169336d72e582e8f0632964426ebcc642ea0d
parent899c44c3fc73c3ce88e9af1ee7aff6fb3e2b1c47 (diff)
downloadopenembedded-c711c4c6556bb8744023f3e44edffafc2d2fbfac.tar.gz
realpath: Add update-alternatives
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/realpath/realpath_1.10.bb11
-rw-r--r--recipes/realpath/realpath_1.15.bb12
2 files changed, 20 insertions, 3 deletions
diff --git a/recipes/realpath/realpath_1.10.bb b/recipes/realpath/realpath_1.10.bb
index cd24dabe0b..c6e8d7f8f5 100644
--- a/recipes/realpath/realpath_1.10.bb
+++ b/recipes/realpath/realpath_1.10.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Return the canonicalized absolute pathname"
SECTION = "utility"
PRIORITY = "optional"
LICENSE = "GPLv2"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
file://makefile.patch"
@@ -13,5 +14,13 @@ CFLAGS += "-DVERSION=${PV}"
do_install () {
install -d ${D}${bindir}
- install -p -m 0755 ${S}/realpath ${D}${bindir}
+ install -p -m 0755 ${S}/realpath ${D}${bindir}/realpath.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/realpath realpath realpath.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove realpath realpath.${PN}
}
diff --git a/recipes/realpath/realpath_1.15.bb b/recipes/realpath/realpath_1.15.bb
index d4001d3c6c..74ffe5a0cd 100644
--- a/recipes/realpath/realpath_1.15.bb
+++ b/recipes/realpath/realpath_1.15.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "Return the canonicalized absolute pathname"
SECTION = "utility"
PRIORITY = "optional"
LICENSE = "GPLv2"
+PR = "r2"
-PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
file://fix-common-mk.patch \
file://no-po4a.patch \
@@ -15,7 +15,15 @@ TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {
install -d ${D}${bindir}
- install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}
+ install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}/realpath.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/realpath realpath realpath.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove realpath realpath.${PN}
}
SRC_URI[realpath.md5sum] = "3351ce6e3d0ce255641c8ca9216a8638"