aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-11 20:06:33 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-11 20:06:33 -0700
commit902b98f32ffd35661e43382f47226f65528ff1b1 (patch)
tree075a2d0bad834ab23c957bf75706c1e440313e9a
parentc1c7ff8f442ccededceb363e7d6391ad487de570 (diff)
downloadopenembedded-902b98f32ffd35661e43382f47226f65528ff1b1.tar.gz
unzip: Add update-alternatives to unzip
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/unzip/unzip_552.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes/unzip/unzip_552.bb b/recipes/unzip/unzip_552.bb
index 6e3497e7bb..0decc4a1dc 100644
--- a/recipes/unzip/unzip_552.bb
+++ b/recipes/unzip/unzip_552.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A (de)compression library for the ZIP format"
SECTION = "console/utils"
LICENSE = "Info-ZIP"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/infozip/UnZip%205.x%20and%20earlier/5.52/unzip${PV}.tar.gz"
S = "${WORKDIR}/unzip-5.52"
@@ -19,6 +19,15 @@ do_install() {
oe_runmake -f unix/Makefile install prefix=${D}${prefix}
install -d ${D}${mandir}
mv ${D}${prefix}/man/* ${D}${mandir}
+ mv ${D}${bindir}/unzip ${D}${bindir}/unzip.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/unzip unzip unzip.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove unzip unzip.${PN}
}
SRC_URI[md5sum] = "9d23919999d6eac9217d1f41472034a9"