summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-27 20:25:55 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-27 20:25:55 -0800
commitffb077a13b24ec3b05dc6544334abd96191e9ac4 (patch)
tree8cf4e6b37c3f2b998d0ca0362afa476bd63c70d2
parentf626c0217a83b127953f1f5f6c9fc56c8dcd0c0d (diff)
downloadopenembedded-ffb077a13b24ec3b05dc6544334abd96191e9ac4.tar.gz
git: Upgrade recipes from 1.7.0.2 -> 1.7.3.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/git/files/git-less-hardlinks.diff30
-rw-r--r--recipes/git/git-native_1.7.3.5.bb (renamed from recipes/git/git-native_1.7.0.2.bb)6
-rw-r--r--recipes/git/git_1.7.3.5.bb (renamed from recipes/git/git_1.7.0.2.bb)8
3 files changed, 26 insertions, 18 deletions
diff --git a/recipes/git/files/git-less-hardlinks.diff b/recipes/git/files/git-less-hardlinks.diff
index 183fe8fe31..b1047271f0 100644
--- a/recipes/git/files/git-less-hardlinks.diff
+++ b/recipes/git/files/git-less-hardlinks.diff
@@ -15,9 +15,11 @@ This patch isn't complete though:
---
---- /tmp/Makefile 2010-05-15 09:39:26.000000000 +0200
-+++ git-1.7.0.2/Makefile 2010-05-15 09:44:21.000000000 +0200
-@@ -1453,7 +1453,6 @@
+Index: git-1.7.3.5/Makefile
+===================================================================
+--- git-1.7.3.5.orig/Makefile
++++ git-1.7.3.5/Makefile
+@@ -1619,7 +1619,6 @@ builtin/help.s builtin/help.o: EXTRA_CPP
$(BUILT_INS): git$X
$(QUIET_BUILT_IN)$(RM) $@ && \
@@ -25,7 +27,7 @@ This patch isn't complete though:
ln -s git$X $@ 2>/dev/null || \
cp git$X $@
-@@ -1626,7 +1625,6 @@
+@@ -1936,7 +1935,6 @@ git-http-push$X: revision.o http.o http-
$(REMOTE_CURL_ALIASES): $(REMOTE_CURL_PRIMARY)
$(QUIET_LNCP)$(RM) $@ && \
@@ -33,17 +35,25 @@ This patch isn't complete though:
ln -s $< $@ 2>/dev/null || \
cp $< $@
-@@ -1830,13 +1828,11 @@
- cp "$$bindir/git$X" "$$execdir/git$X"; } ; } && \
- { for p in $(BUILT_INS); do \
+@@ -2134,20 +2132,18 @@ endif
+ } && \
+ for p in $(filter $(install_bindir_programs),$(BUILT_INS)); do \
+ $(RM) "$$bindir/$$p" && \
+- ln "$$bindir/git$X" "$$bindir/$$p" 2>/dev/null || \
+ ln -s "git$X" "$$bindir/$$p" 2>/dev/null || \
+ cp "$$bindir/git$X" "$$bindir/$$p" || exit; \
+ done && \
+ for p in $(BUILT_INS); do \
$(RM) "$$execdir/$$p" && \
- ln "$$execdir/git$X" "$$execdir/$$p" 2>/dev/null || \
ln -s "git$X" "$$execdir/$$p" 2>/dev/null || \
cp "$$execdir/git$X" "$$execdir/$$p" || exit; \
- done; } && \
- { for p in $(REMOTE_CURL_ALIASES); do \
+ done && \
+ remote_curl_aliases="$(REMOTE_CURL_ALIASES)" && \
+ for p in $$remote_curl_aliases; do \
$(RM) "$$execdir/$$p" && \
- ln "$$execdir/git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
++ || \
ln -s "git-remote-http$X" "$$execdir/$$p" 2>/dev/null || \
cp "$$execdir/git-remote-http$X" "$$execdir/$$p" || exit; \
- done; } && \
+ done && \
diff --git a/recipes/git/git-native_1.7.0.2.bb b/recipes/git/git-native_1.7.3.5.bb
index 6dd14cb791..446ee8d5c4 100644
--- a/recipes/git/git-native_1.7.0.2.bb
+++ b/recipes/git/git-native_1.7.3.5.bb
@@ -1,9 +1,9 @@
require git.inc
inherit native
+SRC_URI[src.md5sum] = "8a8cd93b8a4dff0a03c0fdc77253af3e"
+SRC_URI[src.sha256sum] = "41682e4c13b43591b61a96b6f7a549b24863f62dfc4a917b6147c8e708e288a6"
DEPENDS = "openssl-native curl-native zlib-native expat-native"
-PR = "r6"
-SRC_URI[src.md5sum] = "76518fa774b36de81d160b85fa4f19c1"
-SRC_URI[src.sha256sum] = "5601df7fc282fdd66de196b282694eb77dcfc50438f01587de144b3ead1a6b2f"
+PR = "r0"
EXTRA_OECONF_append = " --without-python"
EXTRA_OEMAKE = "NO_TCLTK=1"
diff --git a/recipes/git/git_1.7.0.2.bb b/recipes/git/git_1.7.3.5.bb
index 8f902e774a..b377b3d5aa 100644
--- a/recipes/git/git_1.7.0.2.bb
+++ b/recipes/git/git_1.7.3.5.bb
@@ -1,8 +1,5 @@
require git.inc
-SRC_URI[src.md5sum] = "76518fa774b36de81d160b85fa4f19c1"
-SRC_URI[src.sha256sum] = "5601df7fc282fdd66de196b282694eb77dcfc50438f01587de144b3ead1a6b2f"
-
SRC_URI += "file://git-less-hardlinks.diff"
EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes"
@@ -13,8 +10,9 @@ RDEPENDS_${PN} = "findutils sed"
# Dropbear ssh needs a wrapper script, so install openssh-ssh to make it work out of the box
RRECOMMENDS_${PN} = "openssh-ssh"
-
-PR = "r10"
+SRC_URI[src.md5sum] = "8a8cd93b8a4dff0a03c0fdc77253af3e"
+SRC_URI[src.sha256sum] = "41682e4c13b43591b61a96b6f7a549b24863f62dfc4a917b6147c8e708e288a6"
+PR = "r0"
do_install_append() {
# Fix broken hardlinks