summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2011-01-24 12:01:41 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2011-01-25 12:42:47 +0100
commit997b012d01e5615586a2f18d2c88416cda237295 (patch)
tree355f9164b708bf55f21241a1c25fbb2e201174cc
parent45377629e006687a014864403d271e6c265154f8 (diff)
downloadopenembedded-997b012d01e5615586a2f18d2c88416cda237295.tar.gz
midpath: Make sdl-fixes patch external
Deleted sdl-fixes patch and uploaded it to an external repository because it needs CRLF line endings to apply and git automatically converts CRLF to LF. This should provide a working solution. Bumped PR. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
-rw-r--r--recipes/midpath/files/sdl-fixes.patch20
-rw-r--r--recipes/midpath/midpath-core_0.2+0.3rc2.bb11
2 files changed, 7 insertions, 24 deletions
diff --git a/recipes/midpath/files/sdl-fixes.patch b/recipes/midpath/files/sdl-fixes.patch
deleted file mode 100644
index e8cfcb22e0..0000000000
--- a/recipes/midpath/files/sdl-fixes.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ru midpath-0.3rc2.orig/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java midpath-0.3rc2/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java
---- midpath-0.3rc2.orig/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java 2008-09-02 03:03:19.000000000 +0300
-+++ midpath-0.3rc2/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java 2010-12-24 13:00:38.313333419 +0200
-@@ -119,6 +119,7 @@
-
- try {
- SDLMain.init(SDLMain.SDL_INIT_VIDEO);
-+ SDLVideo.showCursor(SDLVideo.SDL_DISABLE);
- screenSurface = SDLVideo.setVideoMode(canvasWidth, canvasHeight, bitsPerPixel, flags);
- rootARGBSurface = SDLVideo.createRGBSurface(SDLVideo.SDL_SWSURFACE, canvasWidth, canvasHeight, 32, 0x00ff0000L, 0x0000ff00L,
- 0x000000ffL, 0xff000000L);
-@@ -155,6 +156,8 @@
-
- try {
- SDLEvent.enableUNICODE(1);
-+ SDLEvent.enableKeyRepeat(SDLEvent.SDL_DEFAULT_REPEAT_DELAY,
-+ SDLEvent.SDL_DEFAULT_REPEAT_INTERVAL);
- while (Thread.currentThread() == thread) {
- processEvent(SDLEvent.waitEvent(true));
- }
diff --git a/recipes/midpath/midpath-core_0.2+0.3rc2.bb b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
index 6fe3447d9a..16d014c83c 100644
--- a/recipes/midpath/midpath-core_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
@@ -1,17 +1,17 @@
DESCRIPTION = "MIDPath is a Java library which provides a MIDP2 implementation"
-PR = "r5"
+PR = "r6"
SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz \
- file://configuration.cfg \
- file://ui-colors.patch \
- file://sdl-fixes.patch"
+ file://configuration.cfg"
S = "${WORKDIR}/midpath-0.3rc2"
require midpath-common.inc
SRC_URI += "\
+ http://jlime.com/downloads/development/patches/sdl-fixes.patch;name=patch \
+ file://ui-colors.patch \
file://fix-openfile.patch \
file://hci_read_local_name.patch \
file://midpath-suitemanager \
@@ -92,3 +92,6 @@ FILES_${PN} = "\
SRC_URI[md5sum] = "d03cd88f51f82bbcfcfa5b65df0da5b0"
SRC_URI[sha256sum] = "e235ca7470e7cdfb90e3806fbcc1b2c450db286276136a2523c7ae26a804a100"
+
+SRC_URI[patch.md5sum] = "31d8e20f9d89fd77e9c855bfefc58c22"
+SRC_URI[patch.sha256sum] = "5fadd05567ed95c4012ba1685344a34ee73c67016cfab43b0db5a1508f4c22da"