summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan D Phillips <ryan_d_phillips@dell.com>2011-01-28 00:10:45 +0000
committerTom Rini <tom_rini@mentor.com>2011-01-27 11:24:35 -0700
commit7298be1f35f88c4646a47a59e2ac96e5efa5b39a (patch)
treeee22c902d75f6129f8f93a99807e320ee0ff4a21
parent8e4ad8fe121f84211e2844d95719964e14975013 (diff)
downloadopenembedded-7298be1f35f88c4646a47a59e2ac96e5efa5b39a.tar.gz
bind: Add DISTRO_FEATURES support for ipv6
Signed-off-by: Ryan D Phillips <ryan_d_phillips@dell.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/bind/bind_9.3.1.bb6
-rw-r--r--recipes/bind/bind_9.3.4-P1.bb6
-rw-r--r--recipes/bind/bind_9.3.5-P1.bb6
-rw-r--r--recipes/bind/bind_9.3.6.bb7
4 files changed, 17 insertions, 8 deletions
diff --git a/recipes/bind/bind_9.3.1.bb b/recipes/bind/bind_9.3.1.bb
index 268253e95f..11d4c71905 100644
--- a/recipes/bind/bind_9.3.1.bb
+++ b/recipes/bind/bind_9.3.1.bb
@@ -1,7 +1,7 @@
DEPENDS = "openssl"
RPEDENDS = ""
DESCRIPTION = "ISC Internet Domain Name Server"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.1/bind-9.3.1.tar.gz \
file://lib_dns_Makefile.in.patch \
@@ -9,7 +9,9 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.1/bind-9.3.1.tar.gz \
file://conf.patch \
"
-EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
+EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
+ --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.4-P1.bb b/recipes/bind/bind_9.3.4-P1.bb
index 70c261e9f7..f8ae48fc2f 100644
--- a/recipes/bind/bind_9.3.4-P1.bb
+++ b/recipes/bind/bind_9.3.4-P1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
DEPENDS = "openssl"
@@ -12,7 +12,9 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.4-P1/bind-9.3.4-P1.tar.gz \
file://so_bsdcompat.patch \
"
-EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
+EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
+ --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.5-P1.bb b/recipes/bind/bind_9.3.5-P1.bb
index bb9826184d..f573e57876 100644
--- a/recipes/bind/bind_9.3.5-P1.bb
+++ b/recipes/bind/bind_9.3.5-P1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
DEPENDS = "openssl"
@@ -12,7 +12,9 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.5-P1/bind-9.3.5-P1.tar.gz \
file://so_bsdcompat.patch \
"
-EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
+EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
+ --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.6.bb b/recipes/bind/bind_9.3.6.bb
index b10d6e84ed..2ea37f9fd7 100644
--- a/recipes/bind/bind_9.3.6.bb
+++ b/recipes/bind/bind_9.3.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r1"
+PR = "r2"
DEPENDS = "openssl"
@@ -11,7 +11,10 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${PN}-${PV}.tar.gz \
file://configure.in.patch \
"
-EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr --disable-devpoll --disable-epoll"
+EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
+ --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr --disable-devpoll \
+ --disable-epoll \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"