summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-28 09:17:00 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-28 09:18:35 +0100
commit70e46e545095a2b2dac634d484eb1c331a1bff34 (patch)
treebd38774cc80aa011428c1d1e51f3361ff3ec5750
parent1ecddfca9156dfbb03569a313f53bfdb539a72a3 (diff)
downloadopenembedded-70e46e545095a2b2dac634d484eb1c331a1bff34.tar.gz
avahi: integrate python into main recipe
* this doesn't introduce spurious rdepends like enabling gtk did in the past Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/avahi/avahi-python_0.6.25.bb21
-rw-r--r--recipes/avahi/avahi-ui_0.6.25.bb6
-rw-r--r--recipes/avahi/avahi.inc18
3 files changed, 13 insertions, 32 deletions
diff --git a/recipes/avahi/avahi-python_0.6.25.bb b/recipes/avahi/avahi-python_0.6.25.bb
deleted file mode 100644
index d38acfcc8c..0000000000
--- a/recipes/avahi/avahi-python_0.6.25.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-require avahi.inc
-PR = "${INC_PR}.0"
-
-# FIXME: without --enable-gtk, avahi-discover (pygtk) won't be built
-FILES_avahi-discover = ""
-
-PROVIDES = "avahi"
-DEPENDS += "python-native"
-
-SRC_URI += "file://configure-check-pymod.patch"
-
-S = "${WORKDIR}/avahi-${PV}"
-
-RDEPENDS_avahi-discover = "python-avahi python-pygtk"
-RDEPENDS_python-avahi = "python-dbus"
-PACKAGES =+ "python-avahi"
-
-AVAHI_PYTHON = "--enable-python"
-
-SRC_URI[md5sum] = "a83155a6e29e3988f07e5eea3287b21e"
-SRC_URI[sha256sum] = "9220d974f5515b8ccfa3900cd72cedcac0fa4cc87ca3c64405f7c55346cbba59"
diff --git a/recipes/avahi/avahi-ui_0.6.25.bb b/recipes/avahi/avahi-ui_0.6.25.bb
index 2c44d671a3..6ae35ef33b 100644
--- a/recipes/avahi/avahi-ui_0.6.25.bb
+++ b/recipes/avahi/avahi-ui_0.6.25.bb
@@ -7,12 +7,6 @@ AVAHI_GTK = "--enable-gtk"
S = "${WORKDIR}/avahi-${PV}"
-do_stage() {
- install -d ${STAGING_INCDIR}/avahi-ui
- cp ${S}/avahi-ui/*.h ${STAGING_INCDIR}/avahi-ui/
- oe_libinstall -C avahi-ui -a -so libavahi-ui ${STAGING_LIBDIR}
-}
-
PACKAGES = "${PN} ${PN}-dbg"
FILES_${PN} = "${libdir}/libavahi-ui*.so.*"
diff --git a/recipes/avahi/avahi.inc b/recipes/avahi/avahi.inc
index 4805c6f044..4a7fe929dc 100644
--- a/recipes/avahi/avahi.inc
+++ b/recipes/avahi/avahi.inc
@@ -4,8 +4,8 @@ HOMEPAGE = "http://avahi.org"
SECTION = "network"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "expat virtual/libintl libdaemon dbus glib-2.0"
-INC_PR = "r11"
+DEPENDS = "python-native expat virtual/libintl libdaemon dbus glib-2.0"
+INC_PR = "r12"
# uclibc has no nss
RRECOMMENDS_avahi-daemon_append_libc-glibc = "libnss-mdns"
RDEPENDS_avahi-daemon += "sysvinit-pidof update-rc.d"
@@ -20,13 +20,18 @@ inherit autotools pkgconfig update-rc.d python-dir
# TODO: build and enable all the extra stuff avahi offers
EXTRA_OECONF = "--with-distro=debian --disable-stack-protector --disable-nls --disable-gdbm ${AVAHI_GTK} --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 ${AVAHI_PYTHON}"
-AVAHI_PYTHON = "--disable-python"
-AVAHI_GTK = "--disable-gtk"
+AVAHI_PYTHON ?= "--enable-python"
+AVAHI_GTK ?= "-disable-gtk"
LDFLAGS_append_libc-uclibc = " -lintl"
LDFLAGS_append_uclinux-uclibc = " -lintl"
-PACKAGES =+ "avahi-daemon avahi-discover libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib libavahi-ui avahi-discover-standalone avahi-autoipd avahi-utils"
+do_configure_prepend() {
+ sed 's:AM_CHECK_PYMOD:echo "no pymod" #AM_CHECK_PYMOD:g' -i configure.ac
+}
+
+
+PACKAGES =+ "python-avahi avahi-daemon avahi-discover libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib libavahi-ui avahi-discover-standalone avahi-autoipd avahi-utils"
FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
@@ -58,6 +63,9 @@ FILES_avahi-discover-standalone = "${bindir}/avahi-discover-standalone \
${datadir}/avahi/interfaces/avahi-discover.glade"
CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+RDEPENDS_avahi-discover = "python-avahi python-pygtk"
+RDEPENDS_python-avahi = "python-dbus"
+
INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"