summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2011-01-24 15:48:59 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-24 16:01:49 +0100
commit4f24435fbba0e810c5fdf557e25eb84093837853 (patch)
treea9a93cb86ad38fec8585887f6ad5878a1daa2a65
parente0ec546d18d38ab31ef2787e092be7f9ceba112c (diff)
downloadopenembedded-4f24435fbba0e810c5fdf557e25eb84093837853.tar.gz
linux-omap4: fix break caused by the new binutils
According to this discussion [1], a couple patches where required by the kernel using the latest binutils (2.21). This patch add those patches, which were posted in the Ubuntu's kernel repository. 1. http://comments.gmane.org/gmane.comp.handhelds.openembedded/40650 Signed-off-by: Víctor Manuel Jáquez Leal <vjaquez@igalia.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch38
-rw-r--r--recipes/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch26
-rw-r--r--recipes/linux/linux-omap4_2.6.35.3.bb2
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch b/recipes/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch
new file mode 100644
index 0000000000..e83a3e2501
--- /dev/null
+++ b/recipes/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch
@@ -0,0 +1,38 @@
+From 7699704e011db864c56f333bce9936a36522fb79 Mon Sep 17 00:00:00 2001
+From: Tim Gardner <tim.gardner@canonical.com>
+Date: Thu, 9 Dec 2010 08:16:52 -0700
+Subject: [PATCH 1/2] UBUNTU: [Config] Fix FTBS caused by new binutils
+
+New assemblers need -march=armv7-a+sec on command line or
+.arch_extension sec inline to enable use of the smc instruction.
+
+This patch uses as-instr to check the latter to conditionally
+enable the former in AFLAGS for files that use smc.
+
+Checked on both old and new binutils to verify that it does
+not break old versions.
+
+Signed-off-by: John Rigby <john.rigby@linaro.org>
+Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
+---
+ arch/arm/mach-omap2/Makefile | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
+index 75251b4..0241b4d 100644
+--- a/arch/arm/mach-omap2/Makefile
++++ b/arch/arm/mach-omap2/Makefile
+@@ -29,7 +29,9 @@ obj-$(CONFIG_HOTPLUG_CPU) += omap-hotplug.o
+ obj-$(CONFIG_ARCH_OMAP4) += omap44xx-smc.o omap4-common.o \
+ omap4-wakeupgen.o
+
+-AFLAGS_omap44xx-smc.o :=-Wa,-march=armv7-a
++plus_sec := $(call as-instr,.arch_extension sec,+sec)
++AFLAGS_omap-headsmp.o :=-Wa,-march=armv7-a$(plus_sec)
++AFLAGS_omap44xx-smc.o :=-Wa,-march=armv7-a$(plus_sec)
+
+ # Functions loaded to SRAM
+ obj-$(CONFIG_ARCH_OMAP2420) += sram242x.o
+--
+1.7.0.2
+
diff --git a/recipes/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch b/recipes/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch
new file mode 100644
index 0000000000..ea16ab113a
--- /dev/null
+++ b/recipes/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch
@@ -0,0 +1,26 @@
+From da58d36fb6b13899249bf1efbf25f7385d048bb3 Mon Sep 17 00:00:00 2001
+From: Tim Gardner <tim.gardner@canonical.com>
+Date: Tue, 14 Dec 2010 06:56:34 -0700
+Subject: [PATCH 2/2] Add AFLAGS for sleep44xx to fix FTBS
+
+Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
+---
+ arch/arm/mach-omap2/Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
+index 0241b4d..865a3e2 100644
+--- a/arch/arm/mach-omap2/Makefile
++++ b/arch/arm/mach-omap2/Makefile
+@@ -59,6 +59,8 @@ obj-$(CONFIG_ARCH_OMAP4) += pm44xx.o pm_bus.o cpuidle44xx.o \
+ omap4-mpuss-lowpower.o sleep44xx.o \
+ voltage.o opp44xx_data.o
+
++AFLAGS_sleep44xx.o :=-Wa,-march=armv7-a$(plus_sec)
++
+ obj-$(CONFIG_PM_DEBUG) += pm-debug.o
+ obj-$(CONFIG_OMAP_SMARTREFLEX) += sr_device.o smartreflex.o
+ obj-$(CONFIG_OMAP_SMARTREFLEX_CLASS3) += smartreflex-class3.o
+--
+1.7.0.2
+
diff --git a/recipes/linux/linux-omap4_2.6.35.3.bb b/recipes/linux/linux-omap4_2.6.35.3.bb
index 4db0b284ee..f5a11f4c1e 100644
--- a/recipes/linux/linux-omap4_2.6.35.3.bb
+++ b/recipes/linux/linux-omap4_2.6.35.3.bb
@@ -15,6 +15,8 @@ SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol
file://0006-ARM-Add-option-to-allow-userspace-access-to-performa.patch \
file://0007-OMAP4-do-not-force-select-options-which-are-not-requ.patch \
file://0008-omap4-pandaboard-add-support-for-DVI-output.patch \
+ file://0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch \
+ file://0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch \
file://defconfig"
S = "${WORKDIR}/git"