summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-27 13:41:26 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-27 13:41:53 -0700
commit4b632377f15b965904a1ba4316608f235f5c74ae (patch)
tree08cccf501cb028c628dda7f748d07434531f0785
parent9c66f0a21b1fcbc302dbac18bab6f473f9e06f4a (diff)
downloadopenembedded-4b632377f15b965904a1ba4316608f235f5c74ae.tar.gz
Revert "bind: Add DISTRO_FEATURES support for ipv6"
As Khem noted this is no longer needed. This reverts commit 7298be1f35f88c4646a47a59e2ac96e5efa5b39a.
-rw-r--r--recipes/bind/bind_9.3.1.bb6
-rw-r--r--recipes/bind/bind_9.3.4-P1.bb6
-rw-r--r--recipes/bind/bind_9.3.5-P1.bb6
-rw-r--r--recipes/bind/bind_9.3.6.bb7
4 files changed, 8 insertions, 17 deletions
diff --git a/recipes/bind/bind_9.3.1.bb b/recipes/bind/bind_9.3.1.bb
index 11d4c71905..268253e95f 100644
--- a/recipes/bind/bind_9.3.1.bb
+++ b/recipes/bind/bind_9.3.1.bb
@@ -1,7 +1,7 @@
DEPENDS = "openssl"
RPEDENDS = ""
DESCRIPTION = "ISC Internet Domain Name Server"
-PR = "r2"
+PR = "r1"
SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.1/bind-9.3.1.tar.gz \
file://lib_dns_Makefile.in.patch \
@@ -9,9 +9,7 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.1/bind-9.3.1.tar.gz \
file://conf.patch \
"
-EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
- --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
- ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.4-P1.bb b/recipes/bind/bind_9.3.4-P1.bb
index f8ae48fc2f..70c261e9f7 100644
--- a/recipes/bind/bind_9.3.4-P1.bb
+++ b/recipes/bind/bind_9.3.4-P1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r1"
+PR = "r0"
DEPENDS = "openssl"
@@ -12,9 +12,7 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.4-P1/bind-9.3.4-P1.tar.gz \
file://so_bsdcompat.patch \
"
-EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
- --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
- ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.5-P1.bb b/recipes/bind/bind_9.3.5-P1.bb
index f573e57876..bb9826184d 100644
--- a/recipes/bind/bind_9.3.5-P1.bb
+++ b/recipes/bind/bind_9.3.5-P1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r1"
+PR = "r0"
DEPENDS = "openssl"
@@ -12,9 +12,7 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.5-P1/bind-9.3.5-P1.tar.gz \
file://so_bsdcompat.patch \
"
-EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
- --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr \
- ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"
diff --git a/recipes/bind/bind_9.3.6.bb b/recipes/bind/bind_9.3.6.bb
index 2ea37f9fd7..b10d6e84ed 100644
--- a/recipes/bind/bind_9.3.6.bb
+++ b/recipes/bind/bind_9.3.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ISC Internet Domain Name Server"
SECTION = "console/network"
HOMEPAGE = "http://www.isc.org/sw/bind/"
LICENSE = "BSD"
-PR = "r2"
+PR = "r1"
DEPENDS = "openssl"
@@ -11,10 +11,7 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${PN}-${PV}.tar.gz \
file://configure.in.patch \
"
-EXTRA_OECONF = "--with-randomdev=/dev/random --disable-threads \
- --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr --disable-devpoll \
- --disable-epoll \
- ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6=yes', '--enable-ipv6=no', d)}"
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr --disable-devpoll --disable-epoll"
inherit autotools update-rc.d
INITSCRIPT_NAME = "bind"