summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-23 17:36:44 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-23 17:49:03 -0800
commit4140085f8a41e232d00a1ca5c7c679e1a70a7a65 (patch)
tree692e321713e4fd4192cdde1e54aea06f6863d5dd
parentf90b785681ac2a5aa8a07daaed3209e397f1919a (diff)
downloadopenembedded-4140085f8a41e232d00a1ca5c7c679e1a70a7a65.tar.gz
opensp_1.5.bb: Fix compilation failure seen with -Os/gcc-4.5, Bugzilla/5494
This has been reported many times on mailing list and also in bugzilla/5494 The problem seems to be that gcc is not inlining the functions marked inline in class definitions and emits calls to them but then there is no definitions of these functions elsewhere. I dont know the real cause yet could be a gcc problem. Problem is when compiling armeb-oe-linux-uclibceabi-g++ -march=armv5te -mtune=xscale -DHAVE_CONFIG_H -I. -I.. -I../include -I../generic -isystem/scratch/oe/sysroots/armv5teb-oe-linux-uclibceabi/usr/include -isystem/scratch/oe/sysroots/armv5teb-oe-linux-uclibceabi/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -pipe -fpermissive -fvisibility-inlines-hidden -fvisibility-inlines-hidden -MT SgmlsEventHandler.o -MD -MP -MF .deps/SgmlsEventHandler.Tpo -c -o SgmlsEventHandler.o SgmlsEventHandler.cxx Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/opensp/opensp_1.5.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes/opensp/opensp_1.5.bb b/recipes/opensp/opensp_1.5.bb
index 13d0534dc3..489614d397 100644
--- a/recipes/opensp/opensp_1.5.bb
+++ b/recipes/opensp/opensp_1.5.bb
@@ -4,10 +4,12 @@ XML documents."
HOMEPAGE = "http://openjade.sourceforge.net/"
SECTION = "libs"
LICENSE = "MIT"
-PR = "r2"
+PR = "r3"
-# sh4/gcc3.4.4 with -O2 triggers internal compiler errors
-FULL_OPTIMIZATION_sh4 = "-O1"
+# At Os it encounters calls to some inline functions which are them not found
+# in anyother objects with gcc 4.5
+
+FULL_OPTIMIZATION += "-O2"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
file://m4.patch \