summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-28 10:45:33 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-28 10:50:17 +0100
commit2484007178e3745907d291657fca68d7c6513ca3 (patch)
treeaaf25c9f6bf47ac04a4e64ff61d67b35d2202e97
parent70e46e545095a2b2dac634d484eb1c331a1bff34 (diff)
downloadopenembedded-2484007178e3745907d291657fca68d7c6513ca3.tar.gz
libgles-omap3: add 4.03.00.01 release
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb31
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb47
2 files changed, 78 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb b/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb
new file mode 100644
index 0000000000..4b3a3fcffe
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_4.03.00.01.bb
@@ -0,0 +1,31 @@
+# untested and huge change from 1.4.x
+DEFAULT_PREFERENCE = "-1"
+
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+ES2LOCATION = "${S}/gfx_rel_es2.x"
+ES3LOCATION = "${S}/gfx_rel_es3.x"
+ES5LOCATION = "${S}/gfx_rel_es5.x"
+
+require libgles-omap3.inc
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
+
+SGXPV = "4_03_00_01"
+IMGPV = "1.6.16.3977"
+BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
+ file://cputype \
+ file://rc.pvr \
+ file://sample.desktop \
+ file://99-bufferclass.rules \
+"
+
+SRC_URI[md5sum] = "4163ee51bc05689b6f61e7eadf5ab9cf"
+SRC_URI[sha256sum] = "1afe0dc4974c3c0a0ccf267a531d0964459d1cdf1929e732958230641973da94"
+
+S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
+
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
new file mode 100644
index 0000000000..5dd80fd7f8
--- /dev/null
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb
@@ -0,0 +1,47 @@
+# untested and huge change from 1.4.x
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
+LICENSE = "GPLv2"
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
+
+TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
+require ../ti/ti-eula-unpack.inc
+
+SGXPV = "4_03_00_01"
+IMGPV = "1.6.16.3977"
+BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+inherit module
+
+MACHINE_KERNEL_PR_append = "h"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
+"
+SRC_URI[md5sum] = "4163ee51bc05689b6f61e7eadf5ab9cf"
+SRC_URI[sha256sum] = "1afe0dc4974c3c0a0ccf267a531d0964459d1cdf1929e732958230641973da94"
+
+S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM"
+
+PVRBUILD = "release"
+
+PACKAGE_STRIP = "no"
+
+TI_PLATFORM_omap3 = "omap3630"
+TI_PLATFORM_ti816x = "ti8168"
+
+MODULESLOCATION_omap3 = "dc_omap3430_linux"
+MODULESLOCATION_ti816x = "dc_ti8168_linux"
+
+MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+ cp ${S}/pvrsrvkm.ko \
+ ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
+ ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
+ ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
+}