summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-26 16:10:46 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-26 10:42:27 -0800
commit1a9a5b145cad7d4c5e5d5533886f21db454b9ec5 (patch)
tree0f6cd0919e005c2ba0835724c4f492cd38d21a9a
parent9f1ba8973fc45dfeb5ba251b223e238edb875c76 (diff)
downloadopenembedded-1a9a5b145cad7d4c5e5d5533886f21db454b9ec5.tar.gz
samba: Fix build issue on uclibc/arm/thumb
We get following errors as of now. This patch fixes those /scratch/oe/sysroots/x86_64-linux/usr/armv5te/lib/gcc/arm-oe-linux-uclibceabi/4.5.3/../../../../arm-oe-linux-uclibceabi/bin/ld: /scratch/oe/sysroots/armv5te-oe-linux-uclibceabi/usr/lib//uclibc_nonshared.a(atexit.os)(.text+0x12): unresolvable R_ARM_THM_CALL relocation against symbol `__cxa_atexit' Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/samba/samba_3.2.15.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/samba/samba_3.2.15.bb b/recipes/samba/samba_3.2.15.bb
index ef2707ef46..214de5821d 100644
--- a/recipes/samba/samba_3.2.15.bb
+++ b/recipes/samba/samba_3.2.15.bb
@@ -9,7 +9,7 @@ SRC_URI += "file://configure-3.2.8.patch \
SRC_URI[md5sum] = "5a3bcc4927c9643b9f42970d0815b18f"
SRC_URI[sha256sum] = "84281fd1faeffee8558e49dff865dd382abbf78bc1be00f8cb5aa70aeea67d46"
-PR = "r3"
+PR = "r4"
EXTRA_OECONF += "\
SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
@@ -22,6 +22,7 @@ EXTRA_OECONF += "\
samba_cv_HAVE_WRFILE_KEYTAB=yes \
"
+EXTRA_OECONF_append_libc-uclibc = " --disable-pie"
# for arm we always use ARM instruction set
# gcc 4.5 ICE's in thumb mode
# see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46934