summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2011-01-26 00:16:52 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-25 23:20:32 -0800
commit16d02558af40ae63d9581372287084ba3bb60223 (patch)
tree8e9554c7aacaf54d91f760810c19a259af17a995
parent0af5de8b75c8e197df973d6c66f16c17ae508614 (diff)
downloadopenembedded-16d02558af40ae63d9581372287084ba3bb60223.tar.gz
python-scons_1.3.0: add missing dependencies
In order to launch scons in a board it depends on a couple python packages which were not managed by the recipe. This patch adds them. Signed-off-by: Víctor Manuel Jáquez Leal <vjaquez@igalia.com> Acked-by: Koen Kooi <koen@openembedded.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/python/python-scons_1.3.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes/python/python-scons_1.3.0.bb b/recipes/python/python-scons_1.3.0.bb
index 792e3a54f7..a0690d1723 100644
--- a/recipes/python/python-scons_1.3.0.bb
+++ b/recipes/python/python-scons_1.3.0.bb
@@ -3,6 +3,7 @@ SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "GPL"
SRCNAME = "scons"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz;name=scons \
file://toolchain-from-env.SConscript \
@@ -21,3 +22,11 @@ do_install_append() {
NATIVE_INSTALL_WORKS = "1"
BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} = "python-shell \
+ python-stringold \
+ python-lang \
+ python-io \
+ python-fcntl \
+ python-pickle \
+ python-crypt"