summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniele Ricci <daniele.athome@gmail.com>2010-12-07 07:53:03 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-08 00:46:18 +0100
commit9148c53d97607ce206bbd90329f3d055bd896972 (patch)
treec71540e8ce9d860475e346d710e0952ba4c89fe2
parent2f5c9a990ecda29eef1ba5c40e448a07a7f7c475 (diff)
downloadopenembedded-9148c53d97607ce206bbd90329f3d055bd896972.tar.gz
mokohome: new recipe for mokohome replacement from mokosuite2
MokoHome is an improved version of former mokohome contained in package mokosuite2. It has a better configuration system and it will support modules API for writing widgets. Signed-off-by: Daniele Ricci <daniele.athome@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/mokosuite2/mokohome_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mokosuite2/mokohome_git.bb b/recipes/mokosuite2/mokohome_git.bb
new file mode 100644
index 0000000000..33b74bf9b7
--- /dev/null
+++ b/recipes/mokosuite2/mokohome_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - desktop and home screen"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "c7126d6a754b58add0f76d1994a92e2be60705df"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokohome.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/home"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/home/theme.edj
+}