summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2010-12-10 09:31:01 -0500
committerPhilip Balister <philip@balister.org>2010-12-10 09:36:01 -0500
commit48e6a063370a38a35f31a28efd8f6ce6ebf00840 (patch)
tree135e9c9de345dc3d7b48d46e33cd550fc4deff2c
parent369c3002ab5090b925f5b6132cae6f2f72e1593a (diff)
downloadopenembedded-48e6a063370a38a35f31a28efd8f6ce6ebf00840.tar.gz
i2c-tools : Stage i2c-dev.h header as i2c-dev-user.h.
Thanks to John Faith for suggesting this approach on the ML. The problem is i2c-tools overwrites the header staged by the kernel. This breaks programs that depend on the kernel header.
-rw-r--r--recipes/i2c-tools/i2c-tools_3.0.2.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/i2c-tools/i2c-tools_3.0.2.bb b/recipes/i2c-tools/i2c-tools_3.0.2.bb
index 9c5efcccb8..7ad68210de 100644
--- a/recipes/i2c-tools/i2c-tools_3.0.2.bb
+++ b/recipes/i2c-tools/i2c-tools_3.0.2.bb
@@ -17,5 +17,17 @@ do_compile_prepend() {
echo "include eepromer/Module.mk" >> Makefile
}
+do_stage2() {
+ install -d ${STAGING_INCDIR}/linux
+ install -m 0644 include/linux/i2c-dev.h ${STAGING_INCDIR}/linux/i2c-dev-user.h
+}
+addtask stage2 after do_package before do_populate_staging
+
+do_install_append() {
+ install -d ${D}{$includedir}/linux
+ install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
+ rm -f ${D}${includedir}/linux/i2c-dev.h
+}
+
SRC_URI[md5sum] = "b546345ac19db56719dea6b8199f11e0"
SRC_URI[sha256sum] = "0b4d6455a30a3264a60b4d3be55855d996d52ea4f162a2f04ffff378e24f98a2"