summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-11 18:33:34 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-11 18:33:34 -0700
commitc1c7ff8f442ccededceb363e7d6391ad487de570 (patch)
tree86b7141f83bd264bc655601f4f0f2b97d3e88403
parent14c2ce14d5db9ac0c1e9042ed8fb8e30dbbd4b34 (diff)
downloadopenembedded-c1c7ff8f442ccededceb363e7d6391ad487de570.tar.gz
console-tools: Add fgconsole to u-a
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/console-tools/console-tools_0.3.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/console-tools/console-tools_0.3.2.bb b/recipes/console-tools/console-tools_0.3.2.bb
index 5894a3af21..00b1507f68 100644
--- a/recipes/console-tools/console-tools_0.3.2.bb
+++ b/recipes/console-tools/console-tools_0.3.2.bb
@@ -1,7 +1,7 @@
SECTION = "base"
LICENSE = "GPL"
DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
-PR = "r4"
+PR = "r5"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch \
@@ -25,6 +25,7 @@ acpaths = "-I ${WORKDIR}/config"
do_install () {
autotools_do_install
+ mv ${D}${bindir}/fgconsole ${D}${bindir}/fgconsole.${PN}
mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
@@ -32,6 +33,7 @@ do_install () {
}
pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/fgconsole fgconsole fgconsole.${PN} 100
update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
@@ -39,6 +41,7 @@ pkg_postinst_${PN} () {
}
pkg_prerm_${PN} () {
+ update-alternatives --remove fgconsole fgconsole.${PN}
update-alternatives --remove chvt chvt.${PN}
update-alternatives --remove deallocvt deallocvt.${PN}
update-alternatives --remove openvt openvt.${PN}