summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 16:53:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 18:56:44 +0100
commitf4f3e01a0fd50aadc34243c59917c342652f8c2c (patch)
tree7b1d184100dba82fc6d4cf3a51aadb4a2c9be7c2
parent80ddeb77569a65df4022154de7ee7f38b7dc6758 (diff)
downloadopenembedded-f4f3e01a0fd50aadc34243c59917c342652f8c2c.tar.gz
e-wm: drop patches with really old maxrev
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/e17/e-wm/fix-profiles.diff10
-rw-r--r--recipes/e17/e-wm/gsm-segfault-fix.patch28
-rw-r--r--recipes/e17/e-wm/illume-keyboard-flow.patch76
-rw-r--r--recipes/e17/e-wm_svn.bb6
4 files changed, 1 insertions, 119 deletions
diff --git a/recipes/e17/e-wm/fix-profiles.diff b/recipes/e17/e-wm/fix-profiles.diff
deleted file mode 100644
index d6de73457e..0000000000
--- a/recipes/e17/e-wm/fix-profiles.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-===================================================================
---- e/src/bin/e_config.c (revision 39880)
-+++ e/src/bin/e_config.c (revision 39889)
-@@ -1134,5 +1134,5 @@
- }
- dir = e_prefix_data_get();
-- len = snprintf(buf, sizeof(buf), "%s/data/config", dir);
-+ len = snprintf(buf, sizeof(buf), "%s/data/config/", dir);
- if (len >= (int)sizeof(buf))
- return NULL;
diff --git a/recipes/e17/e-wm/gsm-segfault-fix.patch b/recipes/e17/e-wm/gsm-segfault-fix.patch
deleted file mode 100644
index 0bed84a26e..0000000000
--- a/recipes/e17/e-wm/gsm-segfault-fix.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: e/src/modules/illume/e_mod_gad_gsm.c
-===================================================================
---- e/src/modules/illume/e_mod_gad_gsm.c (revision 37617)
-+++ e/src/modules/illume/e_mod_gad_gsm.c (revision 37618)
-@@ -353,7 +353,7 @@
- {
- /* We care only about the provider name right now. All the other status
- * informations get ingnored for the gadget for now */
-- const char *provider, *name, *reg_stat;
-+ const char *provider = 0 , *name = 0, *reg_stat = 0;
- DBusMessageIter iter, a_iter, s_iter, v_iter;
-
- if (!dbus_message_has_signature(msg, "a{sv}")) return NULL;
-@@ -380,10 +380,13 @@
- dbus_message_iter_next(&a_iter);
- }
-
-+ if (!reg_stat) return NULL;
- if (strcmp(reg_stat, "unregistered") == 0) provider = "No Service";
- else if (strcmp(reg_stat, "busy") == 0) provider = "Searching...";
- else if (strcmp(reg_stat, "denied") == 0) provider = "SOS only";
--
-+
-+ if (!provider) return NULL;
-+
- return strdup(provider);
- }
-
diff --git a/recipes/e17/e-wm/illume-keyboard-flow.patch b/recipes/e17/e-wm/illume-keyboard-flow.patch
deleted file mode 100644
index df5a5e5ff6..0000000000
--- a/recipes/e17/e-wm/illume-keyboard-flow.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-Index: e/src/modules/illume-keyboard/e_kbd_int.c
-===================================================================
---- e/src/modules/illume-keyboard/e_kbd_int.c (revision 46510)
-+++ e/src/modules/illume-keyboard/e_kbd_int.c (working copy)
-@@ -434,6 +434,16 @@
- static void
- _e/src/modules/illume-keyboard/e_kbd_int_stroke_handle(E_Kbd_Int *ki, int dir)
- {
-+ /* If the keyboard direction is RTL switch dir 3 and 1
-+ * i.e, make forward backwards and the other way around */
-+ if (ki->layout.direction == E_KBD_INT_DIRECTION_RTL)
-+ {
-+ if (dir == 3)
-+ dir = 1;
-+ else if (dir == 1)
-+ dir = 3;
-+ }
-+
- if (dir == 4) // up
- _e/src/modules/illume-keyboard/e_kbd_int_layout_next(ki);
- else if (dir == 3) // left
-@@ -886,6 +896,10 @@
- if (!f) return;
- ki->layout.directory = ecore_file_dir_get(layout);
- ki->layout.file = eina_stringshare_add(layout);
-+
-+ /* Make the default direction LTR */
-+ ki->layout.direction = E_KBD_INT_DIRECTION_LTR;
-+
- while (fgets(buf, sizeof(buf), f))
- {
- int len;
-@@ -913,6 +927,17 @@
- sscanf(buf, "%*s %i\n", &(ki->layout.fuzz));
- continue;
- }
-+ if (!strcmp(str, "direction"))
-+ {
-+ char direction[4];
-+ sscanf(buf, "%*s %3s\n", direction);
-+ /* If rtl mark as rtl, otherwise make it ltr */
-+ if (!strcmp(direction, "rtl"))
-+ ki->layout.direction = E_KBD_INT_DIRECTION_RTL;
-+ else
-+ ki->layout.direction = E_KBD_INT_DIRECTION_LTR;
-+ continue;
-+ }
- if (!strcmp(str, "key"))
- {
- ky = calloc(1, sizeof(E_Kbd_Int_Key));
-Index: e/src/modules/illume-keyboard/e_kbd_int.h
-===================================================================
---- e/src/modules/illume-keyboard/e_kbd_int.h (revision 46510)
-+++ e/src/modules/illume-keyboard/e_kbd_int.h (working copy)
-@@ -15,6 +15,13 @@
- E_KBD_INT_TYPE_PASSWORD = (1 << 6)
- } E_Kbd_Int_Type;
-
-+/* The natural text direction of the keyboard */
-+typedef enum _E_kbd_Int_Direction
-+{
-+ E_KBD_INT_DIRECTION_LTR = (1 << 0),
-+ E_KBD_INT_DIRECTION_RTL = (1 << 1)
-+} E_Kbd_Int_Direction;
-+
- typedef struct _E_Kbd_Int E_Kbd_Int;
- typedef struct _E_Kbd_Int_Key E_Kbd_Int_Key;
- typedef struct _E_Kbd_Int_Key_State E_Kbd_Int_Key_State;
-@@ -35,6 +42,7 @@
- const char *file;
- int w, h;
- int fuzz;
-+ int direction;
- E_Kbd_Int_Type type;
- Eina_List *keys;
- E_Kbd_Int_Key *pressed;
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index 9c9f0e11cb..e8f6b1eab9 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -7,22 +7,18 @@ PR = "r18"
SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives
+S = "${WORKDIR}/${SRCNAME}"
SRC_URI = "\
${E_SVN}/trunk;module=${SRCNAME};proto=http \
file://enlightenment_start.oe \
file://applications.menu \
- file://gsm-segfault-fix.patch;maxrev=37617 \
- file://fix-profiles.diff;maxrev=39889 \
"
-SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch"
-
SRC_URI_append_shr = " \
file://illume-disable-screensaver.patch \
file://wizard-module-skipping.patch \
file://illume-flaunch-fix.patch \
- file://illume-keyboard-flow.patch;maxrev=46549 \
"
EXTRA_OECONF = "\