aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:30 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:17 +0100
commitdb07755b857885d294256dcafbb0322bb9de056d (patch)
tree51e5e36b69f88847ce5cb0d74bfd805e70286032
parentc63797cc58108fb0a3edc358f6ce349f46c9f4cd (diff)
downloadopenembedded-db07755b857885d294256dcafbb0322bb9de056d.tar.gz
matchbox-desktop: Added layout.patch and modified recipe for jlime.
* Added layout.patch, which modifies the matchbox-desktop layout slightly by moving everything down by 20 pixels. * Modified matchbox-desktop-0.9.1 recipe with SRC_URI_append_jlime, pulling in the above patch for jlime only. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
-rw-r--r--recipes/matchbox-desktop/matchbox-desktop-0.9.1/layout.patch23
-rw-r--r--recipes/matchbox-desktop/matchbox-desktop_0.9.1.bb2
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/matchbox-desktop/matchbox-desktop-0.9.1/layout.patch b/recipes/matchbox-desktop/matchbox-desktop-0.9.1/layout.patch
new file mode 100644
index 0000000000..b1a57b28e0
--- /dev/null
+++ b/recipes/matchbox-desktop/matchbox-desktop-0.9.1/layout.patch
@@ -0,0 +1,23 @@
+diff -ru matchbox-desktop-0.9.1.orig/data/mbdesktop_modules.in matchbox-desktop-0.9.1/data/mbdesktop_modules.in
+--- matchbox-desktop-0.9.1.orig/data/mbdesktop_modules.in 2004-12-01 13:22:33.000000000 +0200
++++ matchbox-desktop-0.9.1/data/mbdesktop_modules.in 2010-10-05 16:34:14.635639164 +0300
+@@ -4,6 +4,6 @@
+ # It can be overridden on a per-user basis by copying this file to ~/.matchbox/
+ # and editing.
+
+-@MBDESKTOP_PLUGIN_DIR@/tasks.so
++# @MBDESKTOP_PLUGIN_DIR@/tasks.so
+ @MBDESKTOP_PLUGIN_DIR@/dotdesktop.so
+ # @MBDESKTOP_PLUGIN_DIR@/simplefilebrowser.so /
+diff -ru matchbox-desktop-0.9.1.orig/src/mbdesktop.c matchbox-desktop-0.9.1/src/mbdesktop.c
+--- matchbox-desktop-0.9.1.orig/src/mbdesktop.c 2004-12-20 19:42:48.000000000 +0200
++++ matchbox-desktop-0.9.1/src/mbdesktop.c 2010-10-05 16:34:10.728179673 +0300
+@@ -957,7 +957,7 @@
+ &mb->workarea_height ) == False )
+ {
+ mb->workarea_x = 0;
+- mb->workarea_y = 0;
++ mb->workarea_y = 20;
+ mb->workarea_width = DisplayWidth(mb->dpy, mb->scr);
+ mb->workarea_height = DisplayHeight(mb->dpy, mb->scr);
+ }
diff --git a/recipes/matchbox-desktop/matchbox-desktop_0.9.1.bb b/recipes/matchbox-desktop/matchbox-desktop_0.9.1.bb
index 99b43da1c1..01b4077c4d 100644
--- a/recipes/matchbox-desktop/matchbox-desktop_0.9.1.bb
+++ b/recipes/matchbox-desktop/matchbox-desktop_0.9.1.bb
@@ -8,6 +8,8 @@ SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-desktop/0.9/matc
file://pkgconfig_fix.patch \
file://mb-desktop-multi-category-matching.patch"
+SRC_URI_append_jlime = " file://layout.patch "
+
RDEPENDS_${PN} += "matchbox-common"
EXTRA_OECONF = "--enable-startup-notification --enable-dnotify"