aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-18 00:21:16 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-18 00:21:56 +0100
commitc3ee19573df658aad2d4caa0a745fcac61583ea4 (patch)
treed64645b7fdc93794b3593163e7c6e906d5c40913
parentc6de2cbbd977a0addde4200f14ea5bf531c72ee1 (diff)
downloadopenembedded-c3ee19573df658aad2d4caa0a745fcac61583ea4.tar.gz
gcc 4.3.1: mangle gfortran.patch to work on 64bit hosts as well
-rw-r--r--packages/gcc/gcc-4.3.1.inc1
-rw-r--r--packages/gcc/gcc-4.3.1/gfortran.patch40
-rw-r--r--packages/gcc/gcc-cross_4.3.1.bb2
-rw-r--r--packages/gcc/gcc_4.3.1.bb2
4 files changed, 43 insertions, 2 deletions
diff --git a/packages/gcc/gcc-4.3.1.inc b/packages/gcc/gcc-4.3.1.inc
index 6bc197e4c5..18195bc9a5 100644
--- a/packages/gcc/gcc-4.3.1.inc
+++ b/packages/gcc/gcc-4.3.1.inc
@@ -66,6 +66,7 @@ SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
# Language Overrides
FORTRAN = ""
JAVA = ""
+FORTRAN_linux-gnueabi = ",fortran"
EXTRA_OECONF_BASE = " --enable-cheaders=c_std --enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
diff --git a/packages/gcc/gcc-4.3.1/gfortran.patch b/packages/gcc/gcc-4.3.1/gfortran.patch
new file mode 100644
index 0000000000..0c42851ce1
--- /dev/null
+++ b/packages/gcc/gcc-4.3.1/gfortran.patch
@@ -0,0 +1,40 @@
+The patch below fixes a crash building libgfortran on arm-linux-gnueabi.
+
+This target doesn't really have a 128-bit integer type, however it does use
+TImode to represent the return value of certain special ABI defined library
+functions. This results in type_for_size(TImode) being called.
+
+Because TImode deosn't correspond to any gfortran integer kind
+gfc_type_for_size returns NULL and we segfault shortly after.
+
+The patch below fixes this by making gfc_type_for_size handle TImode in the
+same way as the C frontend.
+
+Tested on x86_64-linux and arm-linux-gnueabi.
+Applied to trunk.
+
+Paul
+
+2007-05-15 Paul Brook <paul@codesourcery.com>
+
+ gcc/fortran/
+ * trans-types.c (gfc_type_for_size): Handle signed TImode.
+
+Index: gcc-4.2.1/gcc/fortran/trans-types.c
+===================================================================
+--- gcc-4.2.1/gcc/fortran/trans-types.c (revision 170435)
++++ gcc-4.2.1/gcc/fortran/trans-types.c (working copy)
+@@ -1800,6 +1800,13 @@ gfc_type_for_size (unsigned bits, int un
+ if (type && bits == TYPE_PRECISION (type))
+ return type;
+ }
++
++ /* Handle TImode as a special case because it is used by some backends
++ (eg. ARM) even though it is not available for normal use. */
++#if HOST_BITS_PER_WIDE_INT >= 65
++ if (bits == TYPE_PRECISION (intTI_type_node))
++ return intTI_type_node;
++#endif
+ }
+ else
+ {
diff --git a/packages/gcc/gcc-cross_4.3.1.bb b/packages/gcc/gcc-cross_4.3.1.bb
index bfc8561a4c..7a08d62235 100644
--- a/packages/gcc/gcc-cross_4.3.1.bb
+++ b/packages/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r15"
+PR = "r16"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/packages/gcc/gcc_4.3.1.bb b/packages/gcc/gcc_4.3.1.bb
index 4634820ff2..3c2971487a 100644
--- a/packages/gcc/gcc_4.3.1.bb
+++ b/packages/gcc/gcc_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r10"
+PR = "r11"
require gcc-${PV}.inc
require gcc-configure-target.inc