aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-18 00:46:34 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-18 00:47:11 +0100
commit18951738599540f7c53b7af8b3059f302bfc351d (patch)
tree292f559481a325731a588946eae83d365988ad66
parent41f080ef4f7f7e84feb199a01536bfa716377924 (diff)
downloadopenembedded-18951738599540f7c53b7af8b3059f302bfc351d.tar.gz
gst-plugins-ugly: skip package for ENTERPRISE_DISTRO = 1
gst-plugins-ugly-sid: skip package for ENTERPRISE_DISTRO = 0
-rw-r--r--packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb8
-rw-r--r--packages/gstreamer/gst-plugins-ugly/cross-compile.patch16
-rw-r--r--packages/gstreamer/gst-plugins-ugly_0.10.7.bb11
3 files changed, 17 insertions, 18 deletions
diff --git a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
index 950b7f56aa..573fbd61f3 100644
--- a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
@@ -7,3 +7,11 @@ SRC_URI = "\
file://gstsid_autofoo_HACK.patch;patch=1 \
"
S = "${WORKDIR}/gst-plugins-ugly-${PV}"
+
+python() {
+ # Don't build, if we are building an ENTERPRISE distro
+ enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
+ if enterprise == "0":
+ raise bb.parse.SkipPackage("gst-plugins-ugly-sid will only build if ENTERPRISE_DISTRO != 0")
+}
+
diff --git a/packages/gstreamer/gst-plugins-ugly/cross-compile.patch b/packages/gstreamer/gst-plugins-ugly/cross-compile.patch
deleted file mode 100644
index 41c412dcc4..0000000000
--- a/packages/gstreamer/gst-plugins-ugly/cross-compile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- gst-plugins-ugly-0.10.4/configure.ac~cross-compile
-+++ gst-plugins-ugly-0.10.4/configure.ac
-@@ -282,7 +282,7 @@
- LAME_LIBS="-lmp3lame -lm"
- dnl is lame presets available
- LAME_CFLAGS=""
-- AC_TRY_RUN([
-+ AC_TRY_COMPILE([
- #include <lame/lame.h>
- int main (int argc, char *argv[])
- {
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
index fd008b065a..054f0df5aa 100644
--- a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
@@ -1,10 +1,17 @@
require gst-plugins.inc
-PR = "r0"
+PR = "r1"
DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
SRC_URI += "\
-# file://cross-compile.patch;patch=1 \
file://gstmad_16bit.patch;patch=1 \
file://gstsid_autofoo_HACK.patch;patch=1 \
"
+
+python() {
+ # Don't build, if we are building an ENTERPRISE distro
+ enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
+ if enterprise == "1":
+ raise bb.parse.SkipPackage("gst-plugins-ugly will only build if ENTERPRISE_DISTRO != 1")
+}
+