aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-17 15:23:39 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-17 15:23:39 +0100
commit533bb113090601f260d023cafe2ca5e4a8efdfd1 (patch)
tree2863acc0153b520c4f011e46623ed6884e67bcdc
parenteea5cfc239ca4cb89fad5a0c176f01d002f686dd (diff)
downloadopenembedded-533bb113090601f260d023cafe2ca5e4a8efdfd1.tar.gz
angstrom x11vnc xinit: add xinit script to export your x session over VNC - TOTALLY INSECURE -
* Jaadu and Chicken of the VNC pick up your host using mdns, although Jaadu only shows ":0" for each host
-rw-r--r--packages/angstrom/angstrom-x11vnc-xinit.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/angstrom/angstrom-x11vnc-xinit.bb b/packages/angstrom/angstrom-x11vnc-xinit.bb
new file mode 100644
index 0000000000..ee21d81e03
--- /dev/null
+++ b/packages/angstrom/angstrom-x11vnc-xinit.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Script to start a passwordless vnc of the current X session"
+LICENSE = "MIT"
+RDEPENDS = "x11vnc"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/X11/Xinit.d
+ echo "#!/bin/sh" > ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ echo "x11vnc -q -bg -display :0 -forever -avahi" >> ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+ chmod 0755 ${D}/${sysconfdir}/X11/Xinit.d/02vnc
+}
+
+CONFFILES_${PN} += "${sysconfdir}/X11/Xinit.d/02vnc"
+PACKAGE_ARCH = "all"
+